Opened 7 years ago

Closed 7 years ago

#7084 closed defect (not a bug)

‘Canvas image extraction prompt’ displays useless message

Reported by: rransom Owned by: mikeperry
Priority: Medium Milestone:
Component: Firefox Patch Issues Version:
Severity: Keywords:
Cc: adrelanos@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

From 0021-Add-canvas-image-extraction-prompt.patch:

+canvas.siteprompt=This website (%S) attempted to access image data on a canvas.  Blank (white) image data was returned this time.

Why should I care? (OK, I know this is a fingerprinting risk, but please explain that to the user you just popped up a message box at.)

Child Tickets

Change History (4)

comment:1 Changed 7 years ago by mikeperry

The code actually uses the Torbutton strings over those. This was done because we don't have a translation system for Firefox strings.

Here's the Torbutton strings: https://gitweb.torproject.org/torbutton.git/blob/master:/src/chrome/locale/en/torbutton.properties#l47

I think they're slightly better?

comment:2 Changed 7 years ago by mikeperry

Resolution: not a bug
Status: newclosed

comment:3 Changed 7 years ago by proper

Cc: adrelanos@… added
Resolution: not a bug
Status: closedreopened

Mike, please re-consider this.

Please just block "access image data on a canvas". If I understand this right, it's just about this little icon on the left in the url bar.

Life goes on without this icon. Without telling me, I wouldn't even have noticed.

What do you expect the user to do after seeing this message? The only useful reaction is to "never for this site". Does it actually break anything blocking this thing completely?

This warning is really ugly and useless. Please remove it.

comment:4 Changed 7 years ago by mikeperry

Resolution: not a bug
Status: reopenedclosed

It is not about the icon. That is just where the warning appears. The HTML Canvas is a general purpose rendering surface. We display the warning if websites attempt to render image data and then silently extract it, because this is a major, high-entropy, highly stable fingerprinting vector.

However, eliminating this warning entirely makes it impossible to use web-based image editing tools. Sure, these tools might not be prevalent or popular now aside from lolcat generation, but silently breaking them for everyone is not a long-term solution either.

If there really are first/third parties that are drawing to the canvas and silently extracting that data for whatever use, this is something we should bring to the attention of the EFF and other anti-fingerprinting web advocates so they can pressure those sites to stop that activity. That is the right way to handle these messages.

I've updated #7265 to hopefully reduce the prevalence of the message (we can probably simply block third parties and just log, for example) and make it easier to determine the actual offending party. That ticket is on the schedule for the next few months.

Note: See TracTickets for help on using tickets.