Opened 8 years ago

Closed 8 years ago

#7104 closed defect (fixed)

Rewrite rule for Ubuntu One breaks public links

Reported by: beuno Owned by: pde
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords:
Cc: MB, schoen Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When trying to access an Ubuntu One public file (ie, http://ubuntuone.com/7VxC22fZYV04XRWS31kGw1) it gets incorrectly re-written to: https://one.ubuntu.com/7VxC22fZYV04XRWS31kGw1
It needs to be ubuntuone.com

The problem is in: https://gitweb.torproject.org/https-everywhere.git/blob/HEAD:/src/chrome/content/rules/Ubuntu.xml

35 <rule from="https?:(?:www\.)?ubuntuone\.com/"
36 to="https://one.ubuntu.com/" />

Child Tickets

TicketStatusOwnerSummaryComponent
#7101closedpdeNot good url with ubuntuoneHTTPS Everywhere/EFF-HTTPS Everywhere

Change History (3)

comment:1 Changed 8 years ago by pde

Cc: MB schoen added
Status: newaccepted

Hrm. It seems that other parts of the Ubuntu One domain (such as the homepage) actually redirect over to one.ubuntu.com. So there are a few strategies we could try here:

  1. try to match the URLs that refer to files actually hosted on Ubuntu One. There are a few different forms, some of which can be observed with the right Google search. There's some risk we would take URLs that are supposed to be on one.ubuntu.com and send them over to ubuntuone.com
  1. Try to rewrite everything from http://one.ubuntu.com to https://ubuntuone.com, because it seems to redirect back to https://one.ubuntu.com when required. I don't like this approach as much.
  1. Declare defeat/chaos, disable the ruleset, and ask Ubuntu for help.

comment:2 in reply to:  1 Changed 8 years ago by beuno

Replying to pde:

Hrm. It seems that other parts of the Ubuntu One domain (such as the homepage) actually redirect over to one.ubuntu.com. So there are a few strategies we could try here:

  1. try to match the URLs that refer to files actually hosted on Ubuntu One. There are a few different forms, some of which can be observed with the right Google search. There's some risk we would take URLs that are supposed to be on one.ubuntu.com and send them over to ubuntuone.com
  1. Try to rewrite everything from http://one.ubuntu.com to https://ubuntuone.com, because it seems to redirect back to https://one.ubuntu.com when required. I don't like this approach as much.
  1. Declare defeat/chaos, disable the ruleset, and ask Ubuntu for help.

I am one of the Ubuntu One developers so I can certainly help you straighten this all out :)

ubuntuone.com is *only* used to serve files. At some point ubuntuone.com was used as the main domain, but it isn't anymore, we don't link to it (and haven't in at least 3 years).
Looking at our logs, only bots access the main website via ubuntuone.com, so it's safe to just flip "http://ubuntuone.com/*" to "https://ubuntuone.com/*" every single time. "one.ubuntu.com" is all https and will remain this way.

comment:3 Changed 8 years ago by pde

Resolution: fixed
Status: acceptedclosed

Okay, we have this patched in git and will probably do a 3.0.2 release later today with this and other fixes:

https://gitweb.torproject.org/https-everywhere.git/commitdiff/061f3c02a9a626318e1db4ff169e7a41239c2941

Note: See TracTickets for help on using tickets.