Opened 7 years ago

Closed 2 years ago

#7194 closed defect (worksforme)

Tor fails to build circuits hours after daemon initialization (12+ hours)

Reported by: cypherpunks Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version: Tor: 0.2.3.22-rc
Severity: Normal Keywords: tor-client
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Upgraded from Tor 0.2.2.36 to 0.2.3.22-rc. I'm observing an issue with Tor 0.2.3.22-rc. After around 12+ hours of uptime for a tor system daemon, tor fails to build circuits even though relays and exit nodes are still online. Tor does not recover on its own, the process must be stopped and restarted. Restarting the daemon "/etc/init.d/tor restart" results in normal behavior and tor starts to build circuits without a problem.

I've attached sanitized log files. The first log shows Tor activity over a two day period. The second log shows output from Tor after restart with "/etc/init.d/tor restart" It's also interesting to note that Tor does not recognize "Excludenodes {uk}"

Without including a copy of torrc, I think it is relevant to mention some additional parameters. Hopefully these aren't the cause of the problem, but it's possible they might interfere in some way.

Client 1
ExcludeNodes {uk}, {us}
ExcludeExitNodes {uk}, {us}
StrictNodes 1

Child Tickets

Attachments (2)

TOR_activity.txt (16.8 KB) - added by cypherpunks 7 years ago.
Tor activity log 10/21/12 - 10/22/12
TOR_restart.txt (2.9 KB) - added by cypherpunks 7 years ago.
Tor restart log - restart initiated after hours of tor failing to build new circuits

Download all attachments as: .zip

Change History (15)

Changed 7 years ago by cypherpunks

Attachment: TOR_activity.txt added

Tor activity log 10/21/12 - 10/22/12

Changed 7 years ago by cypherpunks

Attachment: TOR_restart.txt added

Tor restart log - restart initiated after hours of tor failing to build new circuits

comment:1 Changed 7 years ago by cypherpunks

Also it might be worthwhile to mention that installation package was retrieved from the torproject repo.

http://deb.torproject.org/torproject.org/pool/main/t/tor/

comment:2 Changed 7 years ago by arma

this probably isn't your bug, but: betcha didn't know there's no country code called "uk". the geoip file calls the one i assume you're thinking of "gb".

comment:3 Changed 7 years ago by arma

Component: - Select a componentTor
Keywords: tor-client added

comment:4 Changed 7 years ago by arma

Priority: majornormal

Also, what the heck could you mean by "client 1"?

It expands to setting ClientDNSRejectInternalAddresses to 1 (it already defaults to 1).

comment:5 Changed 7 years ago by arma

Is this repeatable? If so, does it happen when you use a vanilla torrc too?

The logs (at that log level) don't tell me much.

comment:6 Changed 7 years ago by Larkdg

Is this repeatable? If so, does it happen when you use a vanilla torrc too?

Like Arma mentioned: have you tried the "default" /etc/tor/torrc [to test]

Running relay only?

What methods are you using to add/refresh/rotate/remove new & older bridges (if at all?)

e.g., https://bridges.torproject.org

comment:7 Changed 7 years ago by arma

I assume this person is running as a client (not a relay), and not using any bridges.

comment:8 in reply to:  4 Changed 7 years ago by cypherpunks

Replying to arma:

Also, what the heck could you mean by "client 1"?

It expands to setting ClientDNSRejectInternalAddresses to 1 (it already defaults to 1).

Sorry typo in original post. It should have read..

ClientOnly 1

Tor is configured to run as a client, not as relay, nor as a bridge

comment:9 in reply to:  5 ; Changed 7 years ago by cypherpunks

Replying to arma:

Is this repeatable? If so, does it happen when you use a vanilla torrc too?

The logs (at that log level) don't tell me much.

I haven't engaged in testing with a default config. I'll try to test those conditions over the weekend.

I can report this much. This fail to build circuit bug was present in 0.2.2.xx series, but rarely would appear (maybe once every 2+ weeks of uptime) under my torrc config. When the bug did appear, tor would fail to build circuits for a few hours, but would eventually recover and start building again. Under 0.2.3.22-rc, usually after 12+ hours this bug appears, tor fails to build circuits, but never recovers. Restarting the daemon results in circuits building immediately, but this is a workaround.

comment:10 in reply to:  9 ; Changed 7 years ago by Larkdg

Replying to cypherpunks:

Replying to arma:

Is this repeatable? If so, does it happen when you use a vanilla torrc too?

The logs (at that log level) don't tell me much.

I haven't engaged in testing with a default config. I'll try to test those conditions over the weekend.

I can report this much. This fail to build circuit bug was present in 0.2.2.xx series, but rarely would appear (maybe once every 2+ weeks of uptime) under my torrc config. When the bug did appear, tor would fail to build circuits for a few hours, but would eventually recover and start building again. Under 0.2.3.22-rc, usually after 12+ hours this bug appears, tor fails to build circuits, but never recovers. Restarting the daemon results in circuits building immediately, but this is a workaround.

Oct 25 19:54:17.000 [notice] Learned fingerprint 449B6B579516A0C3E3E4D7C0161A6114C6719141 for bridge 95.222.71.31:443
Oct 25 19:54:17.000 [notice] Learned fingerprint 2A22F530A4C1F0CA01D9596E8109CD2D9BB18861 for bridge 108.0.130.119:443
Oct 25 19:54:17.000 [notice] Learned fingerprint 763666CD8B577176EDFD5C633CC26F6909458288 for bridge 37.235.49.14:443
Oct 25 19:54:17.000 [notice] new bridge descriptor 'ec2bridger71690739' (fresh): $38CED087E64C196CFFAB9B6B09E9543015719FB6~ec2bridger71690739 at 46.5$
Oct 25 19:54:17.000 [notice] new bridge descriptor 'Unnamed' (fresh): $7E58563BF387EE4FC1AFC7E89D18930A9600E567~Unnamed at 37.247.49.206
Oct 25 19:54:17.000 [notice] Bridge 'torbridge42' has both an IPv4 and an IPv6 address.  Will prefer using its IPv4 address (85.214.131.213:443).
Oct 25 19:54:17.000 [notice] new bridge descriptor 'torbridge42' (fresh): $9459581B2DA5458D19790C28918CB544B3854C8A~torbridge42 at 85.214.131.213
Oct 25 20:09:23.000 [notice] new bridge descriptor 'gp39ftk' (fresh): $449B6B579516A0C3E3E4D7C0161A6114C6719141~gp39ftk at 95.222.71.31
Oct 25 20:54:28.000 [notice] Bridge 'torbridge42' has both an IPv4 and an IPv6 address.  Will prefer using its IPv4 address (85.214.131.213:443).
Oct 25 20:54:28.000 [notice] new bridge descriptor 'torbridge42' (fresh): $9459581B2DA5458D19790C28918CB544B3854C8A~torbridge42 at 85.214.131.213
Oct 25 21:09:21.000 [notice] new bridge descriptor 'ec2bridger71690739' (fresh): $38CED087E64C196CFFAB9B6B09E9543015719FB6~ec2bridger71690739 at 46.5$
Oct 25 21:09:22.000 [notice] new bridge descriptor 'Unnamed' (fresh): $7E58563BF387EE4FC1AFC7E89D18930A9600E567~Unnamed at 37.247.49.206
Oct 25 21:39:25.000 [notice] new bridge descriptor 'gp39ftk' (fresh): $449B6B579516A0C3E3E4D7C0161A6114C6719141~gp39ftk at 95.222.71.31
Oct 25 21:48:03.000 [notice] Heartbeat: Tor's uptime is 12:00 hours, with 3 circuits open. I've sent 9.99 MB and received 43.45 MB.
Oct 25 22:10:19.000 [notice] no known bridge descriptors running yet; stalling
Oct 25 22:10:19.000 [notice] Our directory information is no longer up-to-date enough to build circuits: No live bridge descriptors.
Oct 25 22:10:20.000 [notice] no known bridge descriptors running yet; stalling
Oct 25 22:10:26.000 [notice] no known bridge descriptors running yet; stalling
Oct 25 22:15:00.000 [notice] no known bridge descriptors running yet; stalling
Oct 25 22:15:05.000 [notice] no known bridge descriptors running yet; stalling
Oct 25 22:15:15.000 [notice] no known bridge descriptors running yet; stalling
Oct 25 22:15:51.000 [notice] no known bridge descriptors running yet; stalling
Oct 25 22:26:29.000 [notice] no known bridge descriptors running yet; stalling
Oct 25 22:28:31.000 [notice] no known bridge descriptors running yet; stalling
Oct 25 22:42:45.000 [notice] no known bridge descriptors running yet; stalling
Oct 25 22:45:48.000 [notice] no known bridge descriptors running yet; stalling
Oct 25 22:46:49.000 [notice] no known bridge descriptors running yet; stalling
Oct 25 22:51:54.000 [notice] no known bridge descriptors running yet; stalling
Oct 25 22:55:58.000 [notice] no known bridge descriptors running yet; stalling
Oct 25 23:02:04.000 [notice] no known bridge descriptors running yet; stalling
Oct 25 23:07:16.000 [notice] Interrupt: exiting cleanly.

I concur with 2.2.22-rc as above happening on a Debian/testing/amd64 [vanilla torrc] and with a SIGHUP via arm-tor seemed to rebuild circuits again. (Will try to monitor this closer than ever before ... I don't like this bug! ;)

[Selfnote: Updating bridges manually from https://bridges.torproject.org/ in Vidalia, removing older bridges (24-48hours old) with newer givens ... bridge monitoring (with tor--arm) has seemed to greatly improve relaying under this configuration. No stalling since Oct 25th.]

comment:11 in reply to:  10 Changed 7 years ago by Larkdg

IGNORE my last comment ... I failed to remember this ticket is for NON-RELAY!

/apologies

comment:12 Changed 6 years ago by nickm

Milestone: Tor: unspecified

(Giving this a milestone so it doesn't drop out of sight)

comment:13 Changed 2 years ago by nickm

Resolution: worksforme
Severity: Normal
Status: newclosed

Hm, this hasn't turned anything up. Closing for now, but if this happens on any supported Tor (0.2.4 or later) please reopen.

Note: See TracTickets for help on using tickets.