Opened 7 years ago

Closed 5 years ago

#7207 closed project (not a bug)

BridgeHerder: A tool to manage bridges

Reported by: aagbsn Owned by:
Priority: Very Low Milestone:
Component: Circumvention/BridgeDB Version:
Severity: Keywords: SponsorZ, tor-cloud, tor-bridge
Cc: isis@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I am working on a tool that will make it easier to manage bridges on systems with multiple addresses. The tool currently detects the IP networks available on a system, configures addresses and ports and launches a configurable number of bridge instances.

Eventually the tool will be able to reconfigure the listening ports and addresses periodically and provide an interactive user nterface.

The idea is to make it easy to rent a dedicated server or VPS, add some IP networks, and use this tool to rotate addresses periodically (or in response to censorship events). I have a box from a provider who claims "Unlimited Free IP Addresses*" and started writing this tool so I could easily use all the addresses available, and then use this as justification for more addresses; rinse and repeat.

With a handful of people running a similar configuration we should be able to double the number of number of listening ports advertised by BridgeDB.

Some things to consider:

What frequency of address:port rotation helps the most people?
Do frequently rotating bridges (e.g. home users with dynamic IPs) see significant usage?
Should this tool be a component of TorCloud?
What other features would be useful?

Comments welcome!

*with justification

Child Tickets

Change History (5)

comment:1 Changed 6 years ago by isis

Cc: isis@… added
Keywords: tor-cloud tor-bridge added
Priority: normalminor
Status: newneeds_information

Was any progress made on this? Can I see it? It sounds useful for TorCloud, and if it could be updated to automatically setup PT bridges, even better.

comment:3 Changed 6 years ago by cypherpunks

Could this be part of tor-arm? That would be nice without having to install "yet another tool".

comment:4 Changed 5 years ago by isis

Priority: minortrivial

Changing priority to "trivial" because there's no visible effort on this, no people clamoring to request this feature, and, secretly, I want to close this ticket.

comment:5 Changed 5 years ago by isis

Resolution: not a bug
Status: needs_informationclosed

Closing, feel free to reopen.

Note: See TracTickets for help on using tickets.