Opened 7 years ago

Closed 7 years ago

#7222 closed defect (not a bug)

Not resizing windows anymore

Reported by: T(A)ILS developers Owned by: mikeperry
Priority: Medium Milestone:
Component: TorBrowserButton Version:
Severity: Keywords:
Cc: tails@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Despite having extensions.torbutton.resize_new_windows and extensions.torbutton.resize_on_toggle enabled, TorBrowser on Linux does not resize the window to multiples of 50px. Panopticlick reports a pretty fingerprintable browser because of that.

This behaviour has been observed on TBB version 2.2.39-3-Linux-x86_64.

In the meantime 2.3.23-alpha-1-dev seems to always return the full screen resolution.

Child Tickets

Change History (4)

comment:1 Changed 7 years ago by mikeperry

The alpha behavior is expected, until we switch our alphas to the ESR series (which contain the resolution patches).

However, the stable TBB should still be setting the initial size of new windows to a 200x100 multiple. We no longer prevent user attempts to resize the window, as I decided it seemed a bit too rude, and with no real fingerprinting benefit.

What does Panopticlick report your screen resolution as? For me, panopticlick, http://browserspy.dk/screen.php and http://eb0b428b.byethost7.com/screen.html all report initial content and desktop window sizes of 200x100 multiples until I resize, zoom, or otherwise change the content window dimensions.

comment:2 Changed 7 years ago by T(A)ILS developers

I confirm that it works as you describe. Unfortunately, when using a tiling window manager, the browser is immediately resized to a different size than its startup size.

A small update to the design document would have prevented this misunderstanding.

The current behaviour is probably quite suboptimal. I think that many users are very likely to maximize their browser and not keep the original window size.

comment:3 Changed 7 years ago by mikeperry

The design doc is unfortunately currently stuck waiting on "death by 1000 cuts" of small updates. See #5273 if you'd like to drop a reminder/make suggestions the next revision. I'll probably update it around the time we start investigating 17.x-ESR, most likely?

Maximization is a concern. I've pondered disabling it or at least warning users first for lack of a better idea. I suppose we could dig deep and figure out how to virtualize a fixed resolution no matter what. There's probably scaling code in FF mobile to do this. It's likely to be quite involved though.

However, I consider tiling window manager users to be a mutant minority. In general, I don't find it worthwhile to design for them, except perhaps through solutions that also serve the normals. (Also, shouldn't their resolution keep changing as more windows are added to a given desktop?)

What do you guys think we should do?

comment:4 Changed 7 years ago by mikeperry

Resolution: not a bug
Status: newclosed

I think this ticket has wandered into the not-a-bug area based on the initial description.

However, I've created #7255 and #7266 for the maximized issues.

Note: See TracTickets for help on using tickets.