Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#7234 closed enhancement (fixed)

Implement DNS test helper that supports backend report generation

Reported by: hellais Owned by: hellais
Priority: Medium Milestone:
Component: Archived/Ooni Version:
Severity: Keywords: ooni_invalid
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

We want to have a DNS resolver that will log all the DNS requests that are coming from ooni-probes and match them up in the final report.

A very simple DNS proxy resolver can be found here: https://gitweb.torproject.org/ooni-probe.git/blob/HEAD:/oonib/testhelpers/dns.py.

Child Tickets

Change History (6)

comment:1 Changed 7 years ago by hellais

Keywords: oonib_test_helpers added

comment:2 Changed 7 years ago by hellais

Keywords: ooni_wishlist added

comment:3 Changed 7 years ago by hellais

Keywords: SponsorH201210 added
Parent ID: #7230
Summary: Implement DNS test helperImplement DNS test helper that supports backend report generation

comment:4 Changed 7 years ago by hellais

Resolution: fixed
Status: newclosed

#7408 better scomposes the issue into sub-ticket, this is a duplicate of that, arg.

comment:5 Changed 7 years ago by hellais

Keywords: SponsorH201210 oonib_test_helpers ooni_wishlist removed
Parent ID: #7230

removing keywords

comment:6 Changed 7 years ago by hellais

Keywords: ooni_invalid added
Note: See TracTickets for help on using tickets.