Opened 7 years ago

Closed 3 years ago

#7249 closed defect (user disappeared)

Ticket #5433 - May Crash It?

Reported by: DasFox Owned by: tbb-team
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Going back to this bug;


https://trac.torproject.org/projects/tor/ticket/5433

This line by ransom;

Changed 7 months ago by rransom

status changed from new to closed
resolution set to not a bug

Vidalia uses Qt, and Vidalia in TBB is configured to use the Clearlooks theme because loading a system-wide Qt theme may crash it. (Different versions of Qt libraries do not mix well.)


Has anyone ever seen a crash when it's set to use GTK+?

I've used the TBB for as long as it's been around and I've never experienced crashes, so when the word 'May' was spoken, what about that it may never be an issue either and can't this be tested and allowed to be simply changed in the preferences by the end-user?

I'm not certain why if this is considered a problem then why does Vidalia still have Apperance options, if the end-user can't use them?

In 'start-tor-browser' I changed the line like this;

./App/vidalia --datadir Data/Vidalia/ -style GTK+

So I'm a bit lost here since this was never explained in the past, if this was closed because this is a defect, what defect are we talking about here and how can this defect be fixed?

Going back to very early 2.2x versions this was working and I only noticed it starting at version 2.2.35-9, so why did it work before this?

THANKS

Child Tickets

Change History (5)

comment:1 Changed 7 years ago by karsten

Component: - Select a componentTor bundles/installation
Owner: set to erinn

comment:2 Changed 5 years ago by erinn

Keywords: needs-triage added

comment:3 Changed 5 years ago by erinn

Component: Tor bundles/installationTor Browser
Owner: changed from erinn to tbb-team

comment:4 Changed 4 years ago by cypherpunks

Severity: Normal
Status: newneeds_information

comment:5 Changed 3 years ago by bugzilla

Keywords: needs-triage removed
Milestone: TorBrowserBundle 2.2.x-stable
Resolution: user disappeared
Status: needs_informationclosed
Note: See TracTickets for help on using tickets.