Opened 5 years ago

Closed 5 years ago

#7251 closed defect (fixed)

test_launch_tor_with_config fails if a secondary tor process is running

Reported by: gsathya Owned by: atagar
Priority: Medium Milestone:
Component: Core Tor/Stem Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Steps to reproduce -
1) start tor
2) start the stem integ tests

======================================================================
                          test.integ.process                          
======================================================================

test_launch_tor_with_config                                  [FAILURE]
test_launch_tor_with_timeout                                 [SUCCESS]

======================================================================
ERROR: test_launch_tor_with_config
----------------------------------------------------------------------
Traceback:
  File "/home/gsathya/stem/test/integ/process.py", line 35, in test_launch_tor_with_config
    completion_percent = 5
  File "/home/gsathya/stem/stem/process.py", line 171, in launch_tor_with_config
    return launch_tor(tor_cmd, None, torrc_path, completion_percent, init_msg_handler, timeout)
  File "/home/gsathya/stem/stem/process.py", line 119, in launch_tor
    raise OSError("Process terminated: %s" % last_problem)
OSError: Process terminated: No, it's still there.  Exiting.

----------------------------------------------------------------------
Ran 2 tests in 7.035s

FAILED

Child Tickets

Change History (1)

comment:1 Changed 5 years ago by atagar

Resolution: fixed
Status: newclosed

Great catch! Repro worked and the issue is now fixed. See the commit description for what was going wrong...

https://gitweb.torproject.org/stem.git/commitdiff/56aac96d6213f28a6b597c640affc7a5a963bf75

Note: See TracTickets for help on using tickets.