Opened 6 years ago

Closed 6 years ago

#7264 closed defect (duplicate)

[Error] We couldn't read a descriptor that is supposedly mmaped in our cache. Is another process running in our data directory? Exiting.

Reported by: Niglin Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version: Tor: 0.2.2.39
Severity: Keywords: tor-client
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

LOG:

[Tue Oct 30 12:34:35 2012] The Tor Software is not Running - Click "Start Tor" in the Vidalia Control Panel to restart the Tor software. If Tor exited unexpectedly, select the "Advanced" tab above for details about any errors encountered.

Oct 29 18:54:36.249 [Notice] Tor v0.2.2.39 (git-bec76476efb71549). This is experimental software. Do not rely on it for strong anonymity. (Running on Windows Vista Service Pack 2 [workstation])
Oct 29 18:54:36.249 [Notice] Initialized libevent version 2.0.20-stable using method win32. Good.
Oct 29 18:54:36.249 [Notice] Opening Socks listener on 127.0.0.1:9050
Oct 29 18:54:36.250 [Notice] Opening Control listener on 127.0.0.1:9051
Oct 29 18:54:36.470 [Notice] Parsing GEOIP file .\Data\Tor\geoip.
Oct 29 18:54:40.964 [Notice] OpenSSL OpenSSL 1.0.1c 10 May 2012 looks like version 0.9.8m or later; I will try SSL_OP to enable renegotiation
Oct 29 18:54:40.965 [Notice] We now have enough directory information to build circuits.
Oct 29 18:54:40.965 [Notice] Bootstrapped 80%: Connecting to the Tor network.
Oct 29 18:54:40.965 [Notice] New control connection opened.
Oct 29 18:54:41.616 [Notice] Bootstrapped 85%: Finishing handshake with first hop.
Oct 29 18:54:42.053 [Notice] Bootstrapped 90%: Establishing a Tor circuit.
Oct 29 18:54:45.109 [Notice] Tor has successfully opened a circuit. Looks like client functionality is working.
Oct 29 18:54:45.110 [Notice] Bootstrapped 100%: Done.
Oct 29 23:41:30.074 [Warning] Error replacing "C:/Users/Niglin/Desktop/Temp/--- TOR ---/Tor Browser/Data/Tor\cached-consensus": File exists
Oct 30 00:58:47.810 [Warning] Error replacing "C:/Users/Niglin/Desktop/Temp/--- TOR ---/Tor Browser/Data/Tor\cached-consensus": File exists
Oct 30 02:07:52.908 [Warning] Error replacing "C:/Users/Niglin/Desktop/Temp/--- TOR ---/Tor Browser/Data/Tor\cached-consensus": File exists
Oct 30 02:50:40.915 [Warning] Error replacing "C:/Users/Niglin/Desktop/Temp/--- TOR ---/Tor Browser/Data/Tor\cached-consensus": File exists
Oct 30 04:04:45.595 [Warning] Error replacing "C:/Users/Niglin/Desktop/Temp/--- TOR ---/Tor Browser/Data/Tor\cached-consensus": File exists
Oct 30 05:10:50.960 [Warning] Error replacing "C:/Users/Niglin/Desktop/Temp/--- TOR ---/Tor Browser/Data/Tor\cached-consensus": File exists
Oct 30 06:37:14.660 [Warning] Error replacing "C:/Users/Niglin/Desktop/Temp/--- TOR ---/Tor Browser/Data/Tor\cached-consensus": File exists
Oct 30 08:10:47.067 [Warning] Error replacing "C:/Users/Niglin/Desktop/Temp/--- TOR ---/Tor Browser/Data/Tor\cached-consensus": File exists
Oct 30 09:48:24.321 [Warning] Error replacing "C:/Users/Niglin/Desktop/Temp/--- TOR ---/Tor Browser/Data/Tor\cached-consensus": File exists
Oct 30 10:59:34.236 [Warning] Error replacing "C:/Users/Niglin/Desktop/Temp/--- TOR ---/Tor Browser/Data/Tor\cached-consensus": File exists
Oct 30 12:06:40.717 [Warning] Error replacing "C:/Users/Niglin/Desktop/Temp/--- TOR ---/Tor Browser/Data/Tor\cached-consensus": File exists
Oct 30 12:34:33.938 [Notice] Application request when we haven't used client functionality lately. Optimistically trying directory fetches again.
Oct 30 12:34:35.742 [Notice] I learned some more directory information, but not enough to build a circuit: We have only 248/836 usable exit node descriptors.
Oct 30 12:34:35.745 [Notice] I learned some more directory information, but not enough to build a circuit: We have only 271/836 usable exit node descriptors.
Oct 30 12:34:35.754 [Notice] We now have enough directory information to build circuits.
Oct 30 12:34:35.760 [Warning] Error replacing old router store: File exists
Oct 30 12:34:35.760 [Error] We couldn't read a descriptor that is supposedly mmaped in our cache. Is another process running in our data directory? Exiting.

Child Tickets

Attachments (1)

VidaliaLog-10.30.2012.txt (3.5 KB) - added by Niglin 6 years ago.
LOG

Download all attachments as: .zip

Change History (7)

Changed 6 years ago by Niglin

Attachment: VidaliaLog-10.30.2012.txt added

LOG

comment:1 Changed 6 years ago by arma

Component: VidaliaTor
Keywords: tor-client added; Crash removed
Priority: majornormal
Summary: TOR - Vidalia Crashing constantly (last 2 versions)[Error] We couldn't read a descriptor that is supposedly mmaped in our cache. Is another process running in our data directory? Exiting.

comment:2 Changed 6 years ago by arma

Owner: chiiph deleted
Status: newassigned

comment:3 Changed 6 years ago by arma

Status: assignednew

comment:4 Changed 6 years ago by arma

Are you running your Tor Browser Bundle from a disk that you can't write to?

Do you have any antivirus things going at the same time, that open all your files and look at them while Tor is trying to write to them?

comment:5 Changed 6 years ago by arma

See also #3186 and #1523 for previous reports here. I assume it's some incompatibility with some other Windows software you're trying to run at the same time.

comment:6 Changed 6 years ago by nickm

Resolution: duplicate
Status: newclosed

Closing as duplicate of #1523

Note: See TracTickets for help on using tickets.