Opened 7 years ago

Closed 6 years ago

#7270 closed defect (fixed)

Rule NYTimes (mixed content) breaks bostonglobe.com site

Reported by: rgb1955 Owned by: pde
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The bostonglobe.com site is broken when https is used. I tried a rule to disable, but I can't seem to get it to work -- the site is still directed to the https unless I completely disable HTTPS Everywhere. Boston Globe has been informed of the issue are claim they are "working on it".

The ruleset I wrote:

<ruleset name="BostonGlobe (buggy)" default_off="breaks picture links">

<target host="www.bostonglobe.com" /><target host="bostonglobe.com" />

</ruleset>

Child Tickets

Attachments (1)

bad-globe.png (330.6 KB) - added by rgb1955 7 years ago.
Screen shot showing missing images and "strange" urls on page

Download all attachments as: .zip

Change History (7)

comment:1 Changed 7 years ago by rgb1955

Also just noted that when HTTPS Everywhere is disabled, then the login to the site goes away. It comes back when HTTPS Everywhere is turned on. When off, the login button on the site is disabled.

comment:2 Changed 7 years ago by rgb1955

Summary: Need rule to disable rules for bostonglobe.comRule NYTimes (mixed content) breaks bostonglobe.com site
Type: enhancementdefect

Been trying various things on the bostonglobe.com site. When I disable the NYTimes (mixed content) rule, then the site works. Updating summary, etc. to reflect this.

comment:3 Changed 7 years ago by pde

I haven't been able to reproduce this (for me, the Boston Globe homepage is fine but individual articles trigger the paywall, but that seems to be the same as I see without HTTPS Everywhere... am I missing something?)

However I just pushed this commit to the 3.0 branch, which will split all the Boston Globe rules into a new ruleset that is off by default:

https://gitweb.torproject.org/https-everywhere.git/commitdiff/d4db86975191d0715ea2da758346b510a31576e5

Changed 7 years ago by rgb1955

Attachment: bad-globe.png added

Screen shot showing missing images and "strange" urls on page

comment:4 Changed 7 years ago by rgb1955

Attached a screen shot. The images from the globe.com site do not appear when one uses https. At work (running on CentOs5  with Firefox 16.0.2) trying to get to the globe site always got re-written to use https. Here at home (Ubuntu 12, Firefox 16.02.) that is not the case -- also I seem to be seeing different rules, though that may simply be due to fact that it's been two days since I've been at work and the rule sets have been updated.

comment:5 in reply to:  3 Changed 7 years ago by rgb1955

Paywall was not a problem, as I have a subscription. It seems that the site doesn't handle secure connections very well.

Replying to pde:

I haven't been able to reproduce this (for me, the Boston Globe homepage is fine but individual articles trigger the paywall, but that seems to be the same as I see without HTTPS Everywhere... am I missing something?)

comment:6 Changed 6 years ago by pde

Resolution: fixed
Status: newclosed

I believe this was fixed in 3.0.4

Note: See TracTickets for help on using tickets.