Opened 7 years ago

Closed 7 years ago

#7372 closed enhancement (duplicate)

Implement SOCKS 5 client

Reported by: hellais Owned by: hellais
Priority: High Milestone:
Component: Archived/Ooni Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

We need to have a socks 5 client to be able to perform TCP requests over Tor.

I would recommend basing the basic SOCKS5 client that is used in tor2web: https://github.com/globaleaks/Tor2web-3.0/blob/master/socksclient.py

Child Tickets

Change History (2)

comment:1 Changed 7 years ago by hellais

Keywords: SponsorH201210 added

Setting this to the third milestone

comment:2 Changed 7 years ago by hellais

Keywords: SponsorH201210 removed
Resolution: duplicate
Status: newclosed

This is a duplicate of 7269

Note: See TracTickets for help on using tickets.