Opened 8 years ago

Closed 4 years ago

Last modified 19 months ago

#7463 closed defect (duplicate)

TOR Browser always reverts to 'use custom settings for history'

Reported by: cypherpunks Owned by: mikeperry
Priority: Medium Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Whenever I change the settings in Privacy preferences to 'Never remember history', the browser immediately reverts that to 'Use custom settings for history'. Even if I come back right after closing the menu, still in the same browser session, the settings are already reset, so of course my changes are not preserved across different sessions either (upon restart the browser one is back to 'Use custom settings for history'). All files in tor-browser_en-US/ are owned by me, so preferences changes should stick. Why is it *not* the behavior?

I am using the latest bundle tor-browser-gnu-linux-x86_64-2.2.39-5-dev-en-US.tar.gz but this issue has been around ever since I tried TOR (all versions since and including tor-browser-gnu-linux-x86_64-2.2.38-2-dev-en-US.tar.gz).

Child Tickets

Change History (6)

comment:1 Changed 8 years ago by arma

Component: Tor bundles/installationTorBrowserButton
Owner: changed from erinn to mikeperry

comment:2 Changed 8 years ago by mikeperry

This is not worth solving until we do #3100 and probably also #3944. In fact, the solution to those two may end up fixing this.

comment:3 Changed 8 years ago by slacka

I have the same issue, only I want to change the preference to "Remember History". I use tor to circumnavigate the Great Firewall of China. Usability is paramount to privacy for me.

Currently using: tor-browser-2.3.25-4_en-US

comment:4 Changed 8 years ago by mikeperry

Status: newneeds_information

I installed a pref observer for this in FF17-ESR. Please describe the exact pref conflict issue you are experiencing.

comment:5 Changed 8 years ago by slacka

Mike,
When you uncheck "Do not record browsing history (Private Mode), it should give the control of the history back to the user.
For example, with a fresh install of tor-browser-2.4.11-alpha-1_en-US
1 Torbutton -> uncheck "Do not record browsing history
2 Options->Privacy->History -> Remember History
3 Options->General->When TorBrowser starts -> Show my Windows from last time
4 Close TorBrowser
5 ReOpen TorBrowser
All of your windows are lost, and the settings that you changed in Options are reverted back to "use custom". This functionality worked in TorButton 1.4.x but is broken in 1.5.x.
Maybe you need another check box in the TorButton, like "Enable user control over privacy settings" to allow 1.4.x like customization.
Thanks for looking into this.

Note: sorry for the dupe. My post in #8457 belongs here

comment:6 Changed 4 years ago by bugzilla

Component: TorBrowserButtonApplications/Tor Browser
Resolution: duplicate
Severity: Normal
Status: needs_informationclosed

Closed as a duplicate of #19369.

Note: See TracTickets for help on using tickets.