Opened 7 years ago

Closed 7 years ago

#7477 closed defect (fixed)

GitHub Pages does not support SSL

Reported by: brainsik Owned by: pde
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version: HTTPS-E 3.0.2
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

GitHub pages, a way for GitHub pages to host web pages at a subdomain of github.com, does not support SSL. https-everywhere tries to redirect to SSL versions of these sites. This breaks Firefox extensions which try to download data from one of those pages.

The main page for this GitHub feature is here:

http://pages.github.com/

The specific page I had a problem with is:

http://sebuilder.github.com/se-builder/

Child Tickets

Change History (2)

comment:1 Changed 7 years ago by pde

What are the specific steps to reproduce the problem? http://sebuilder.github.com/se-builder/ seems to work for me.

comment:2 Changed 7 years ago by brainsik

Resolution: fixed
Status: newclosed

Hello. I am not able to reproduce this with 3.0.4. The problem was on 3.0.2. Perhaps it's been fixed. Thank you for looking into it.

Note: See TracTickets for help on using tickets.