Opened 7 years ago

Closed 7 years ago

#7528 closed defect (not a bug)

Directory authority out of memory

Reported by: ln5 Owned by:
Priority: High Milestone: Tor: 0.2.4.x-final
Component: Core Tor/Tor Version:
Severity: Keywords: tor-auth
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Nov 14 16:45:31.000 [notice] Tor 0.2.4.6-alpha (git-b13c6becc892d971) opening log file.
Nov 20 03:20:13.000 [err] Out of memory on malloc(). Dying.

(TZ CET)

Running on FreeBSD 9.0 (i386).

Child Tickets

Change History (9)

comment:1 Changed 7 years ago by arma

How much memory did you allow it?

comment:2 Changed 7 years ago by ln5

I didn't constrain it.

ulimit shows "unlimited" for both -v and -m.

I'm not sure what this means on a 32-bit system. 3Gb? 4Gb?

comment:3 Changed 7 years ago by arma

I just did a quick run of git master in valgrind, and didn't find any leaks.

Maybe your relay did something mine doesn't do. Or maybe your libc malloc is even fragmentier than mine.

comment:4 Changed 7 years ago by nickm

Keywords: tor-auth added; dirauth removed
Milestone: Tor: 0.2.4.x-final

comment:5 Changed 7 years ago by ln5

Over the last 48h, my tor has been growing with about 1 MB virtual
(vsz) per hour and about half of that resident (rss). It's currently
at 358 MB vsz, 291 MB rss.

It's running 0.2.4.6-alpha-dev (git-ea893a3c30d0e2ed).

comment:6 Changed 7 years ago by nickm

I wonder if dmalloc or valgrind or something could find out if there's something going here. If there isn't a leak, is there some allocation that's growing without bound?

Do you have a handle on what version this might have started with?

comment:7 Changed 7 years ago by ln5

This particular machine is not suitable for debugging I'm afraid.

I'm going to start looking at a couple of other relays; one running as
an authority in a test network, i.e. without any traffic, and one busy
exit relay, to see if I can reproduce it in another environment and
maybe find out more about what triggers it.

Regarding version, 0.2.4.5-alpha-dev (git-03b32161bc377668) didn't
crash when running for about two weeks (from Oct 29 to Nov 13). The
crashing 0.2.4.6-alpha (git-b13c6becc892d971) died in under 6
days. Prior to that, 0.2.4.3-alpha-dev (git-dc014c97472e3adf) ran for
10 days without crashing, FWIW. Not sure what configuration might've
changed between the restarts though, so it's hard to draw any firm
conclusions from this I'm afraid.

Current status for maatuska is 378/312 VSZ/RSS. This means a growth of
about a third of the rate earlier reported. I'm not convinced that the
bug is in 0.2.4.6-alpha-dev (git-ea893a3c30d0e2ed) but keeping the
ticket open for a couple of days more.

comment:8 Changed 7 years ago by arma

ln5, any progress here?

We periodically open "oh my gosh Tor uses lots of memory" tickets, but it seems like fixing memory fragmentation bugs happens independently of whether there are tickets like this one open.

comment:9 Changed 7 years ago by ln5

Resolution: not a bug
Status: newclosed

Right, closing.

Note: See TracTickets for help on using tickets.