Opened 3 years ago

Closed 4 months ago

#7562 closed defect (not a bug)

Toggling toolbars leads to reduced anonymity.

Reported by: malaparte Owned by: tbb-team
Priority: normal Milestone:
Component: Tor Browser Version:
Keywords: tbb-fingerprinting, tbb-torbutton Cc: hack@…
Actual Points: Parent ID:
Points:

Description

If you visit panopticlick.eff.org from the TBB, you're roughly in an anonymity set of 1 in every 4000 users. Now turn off a toolbar in View>Toolbars and your fingerprint is unique or 1 in a million or so. Subsequent restarts of TBB do not toggle the toolbar back to default setting.

I suggest making toggling menu / navigation bars impossible in the TBB.

A scenario where this matters is a case when a user finds their anonymity compromised by accidentally toggling the menu bar off (like I did).

Child Tickets

Change History (7)

comment:1 follow-up: Changed 3 years ago by malaparte

I'm doing some googling to figure out how we can change this now, but I know almost nothing about Firefox.

comment:2 in reply to: ↑ 1 Changed 3 years ago by malaparte

Replying to malaparte:

I'm doing some googling to figure out how we can change this now, but I know almost nothing about Firefox.

I set up something to listen for file modifications and it seems that the file being modified is...

tor-browser_en-US/Data/profile/localstore.rdf

Version: 2.2.39-5 686 md5sum of the tarball 4109ccbcc43a2e644b1a11496fbc54ef

comment:3 Changed 3 years ago by mikeperry

  • Keywords tbb-fingerprinting added

I think this is the same root problem as #6146. See #7255 and #7256 for our best ideas for a solution so far.

However, if we don't make the zoom atomic or the prompt block the toolbar appearance, sites can still detect the resize in both CSS and JS.

This is a hard issue :/.

comment:4 Changed 2 years ago by malaparte_

  • Cc hack@… added

comment:5 Changed 10 months ago by erinn

  • Component changed from TorBrowserButton to Tor Browser
  • Keywords tbb-torbutton added
  • Owner changed from mikeperry to tbb-team

comment:6 Changed 10 months ago by cypherpunks

hello.

I suggest making toggling menu / navigation bars impossible in the TBB.

I dislike this suggestion, it's way too restrictive; what bars i want to toggle on or off should really be my own business if i feel the need to do so. E.g. with small monitors the screen real estate taken up by unnecessary toolbars really does matter, so i might toggle them on/off depending on whether i prioritize convenience or anonymity in that particular situation.

I just posted my own thoughts on these issues in ticket 7256.
TL;DR:

I've been thinking for some time that maybe a better approach to the window size issue would be to increase the amount of "noise" in the user data, rather than trying to shoehorn all users' data into a "uniform" template.
What I'm thinking of is varying the window size by a certain margin/formula on each startup / 'New Identity' (torbutton). Now obviously the variation can't be too great or it will be an anti-feature, but i'd think something around the size/s of the various toolbars/scrollbars/etc. (ca. 25-50px?) wouldn't be too intrusive, and as a bonus would obfuscate what bars individual users have visible (and also i guess window decorations in case those matter?)

comment:7 Changed 4 months ago by mikeperry

  • Resolution set to not a bug
  • Status changed from new to closed

I think toolbar changes are actually no longer an issue with Georg's new rounding code, at least not for me. There are still other issues though.

Note: See TracTickets for help on using tickets.