Opened 11 years ago

Last modified 11 years ago

#758 closed defect (Fixed)

Firefox window is tiny when started with http proxy off

Reported by: arma Owned by: mikeperry
Priority: Low Milestone:
Component: Applications/Torbutton Version: 1.1
Severity: Keywords:
Cc: arma Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When I start my Firefox and it doesn't restore from crash (meaning it just
loads the homepage with Tor enabled), but my polipo is not running, then
Firefox will show me the "proxy connection failed" page. But it immediately
rounds it to the nearest 50 pixels, and apparently that value is 0. So the
firefox window becomes roughly zero sized.

[Automatically added by flyspray2trac: Operating System: All]

Child Tickets

Attachments (1)

torbutton-1.2.0rc5-dev.xpi (191.7 KB) - added by mikeperry 11 years ago.
Does this fix it?

Download all attachments as: .zip

Change History (4)

Changed 11 years ago by mikeperry

Attachment: torbutton-1.2.0rc5-dev.xpi added

Does this fix it?

comment:1 Changed 11 years ago by mikeperry

Hey arma, can you try the attached addon and let me know if this fixes it? There should be a log message at
NOTE to the effect of "Window size damn near zero"..

If not, can you be more specific about your browser state? Do you set torbutton to always start in tor?
Do you have firefox load a homepage at startup? Are you trying to resize your window at any point
during this?

comment:2 Changed 11 years ago by arma

It doesn't happen all the time, and it's best reproduced by running polipo
but no Tor, and restarting firefox with various combinations of "start new
session vs restore old session" and "from a crash vs clean".

I installed the new xpi, and messed with it for a while. After several tries,
I did manage to get torbutton to spit out:
[07-12 08:50:51] Torbutton NOTE: Window size damn near zero: (1, 1)
which presumably means the bug *would* have happened.

So it looks like it's fixed. Yay. I will let you know if it comes back, but
let's assume it's gone now.

comment:3 Changed 11 years ago by mikeperry

flyspray2trac: bug closed.
Fixed in 1.2.0rc6

Note: See TracTickets for help on using tickets.