Opened 8 years ago

Closed 5 years ago

#7585 closed defect (fixed)

CAPTCHA not displayed on topix.com

Reported by: runa Owned by: pde
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Normal Keywords: tbb-usability-website
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

A user reports that she is unable to post on topix.com because the CAPTCHA is not displayed. The site tells users to ensure that javascript and cookies are enabled.

To test this without signing up or logging in:

Child Tickets

Change History (9)

comment:1 Changed 8 years ago by mikeperry

Keywords: tbb-usability-website added

I just tested, and this does not appear to be related to third party cookies. Not sure what is wrong..

comment:2 Changed 8 years ago by mikeperry

Doing the Torbutton settings change dance, and/or changing prefs from https://gitweb.torproject.org/torbrowser.git/blob/HEAD:/build-scripts/config/prefs.js is probably the way forward to diagnosing this.

It might also be the case that their captcha server simply bans some/most/all Tor nodes via some stupid IP rate limiting scheme. Might be worth testing in a vanilla firefox with just SOCKS settings, first?

comment:3 Changed 8 years ago by gk

Component: TorBrowserButtonEFF-HTTPS Everywhere
Owner: changed from mikeperry to pde

Wow. Turns out to be an HTTPS-Everyhwere issue... Leaving the Keywords field though (fearing Mike's wrath ;) ).

comment:4 Changed 8 years ago by pde

I cannot reproduce this with HTTPS Everywhere 3.0.4 (I was able to post the comment here).

Is this a 4.0development branch problem, or has Topix fixed it themselves?

comment:5 Changed 8 years ago by pde

Hmmm, looks like I had disabled the CacheFly ruleset. Re-enabling it triggers the bug.

comment:6 Changed 8 years ago by pde

Resolution: fixed
Status: newclosed

Forcing topix.cachefly.net to http with a downgrade rule seems to fix this. Ugly, but committing.

comment:7 in reply to:  description Changed 6 years ago by djerome2000

Replying to runa:

A user reports that she is unable to post on topix.com because the CAPTCHA is not displayed. The site tells users to ensure that javascript and cookies are enabled.

To test this without signing up or logging in:

I don't know why this is marked as fixed and closed. I was using Tor and Topix was working, though Tor was NOT hiding my ISP. I had to add anonymox to Tor to do that but at least I could post on Topix. Then it stopped allowing me to post through Tor. I uninstalled Tor, reinstalled Tor and still am not allowed to post on Topix, cannot even mark judg-its. Why is this marked fixed and closed and how can this be fixed, or can it not be fixed for Tor?

comment:8 Changed 6 years ago by djerome2000

Resolution: fixed
Status: closedreopened

A user reports that she is unable to post on topix.com because the CAPTCHA is not displayed. The site tells users to ensure that javascript and cookies are enabled.

To test this without signing up or logging in:

Go to ​http://www.topix.com/
Scroll down choose a discussion
Scroll down, choose a comment, and click "Reply"

I don't know why this is marked as fixed and closed. I was using Tor and Topix was working, though Tor was NOT hiding my ISP. I had to add anonymox to Tor to do that but at least I could post on Topix. Then it stopped allowing me to post through Tor. I uninstalled Tor, reinstalled Tor and still am not allowed to post on Topix, cannot even mark judg-its. Why is this marked fixed and closed and how can this be fixed, or can it not be fixed for Tor?

comment:9 Changed 5 years ago by bugzilla

Resolution: fixed
Severity: Normal
Status: reopenedclosed

It works with JS on.

Note: See TracTickets for help on using tickets.