Opened 7 years ago

Closed 7 years ago

Last modified 9 months ago

#7600 closed defect (duplicate)

Edit curr torrc: comments # in the configuration file will lead to " Error at line 1: "" "

Reported by: steve45king Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: 0.2.2.39
Severity: Keywords: torrc comments error
Cc: bastik.public@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

When a comment line is at the beginning or somewhere else in the config-file, you will receive an error ("Error at line 1" when the comments are at the beginning)

Workaround:
1) Delete comments prior to saving the file (using "apply all" setting)
2) mark all configuration parameters except the comments and use option "Apply selection only"

Option "Save settings" is set to on.
OS: Windows7

Here is an example with a config-file with comments:

# This file was generated by Tor; if you edit it, comments will not be preserved
# The old torrc file was renamed to torrc.orig.1 or similar, and Tor will ignore it

AvoidDiskWrites 1
ControlPort 9051
DataDirectory C:/Users/Admin/Downloads/Tor Browser/Data/Tor
DirReqStatistics 0
ExitNodes {ch},{ru},{bg}
GeoIPFile .\Data\Tor\geoip
Log notice stdout
SocksListenAddress 127.0.0.1

Child Tickets

Change History (3)

comment:1 Changed 7 years ago by bastik

Cc: bastik.public@… added

This looks like a duplicate of #6147, unless it's not Vidalia that spits out the error and Tor started to dislike comments, too.

(Maybe my ticket summary wasn't chosen well enough, since you can edit the torrc from within Vidalia and just saving fails)

comment:2 Changed 7 years ago by nickm

Status: newneeds_information

Is this in fact vidalia giving the error?

comment:3 Changed 7 years ago by arma

Resolution: duplicate
Status: needs_informationclosed

Closing as duplicate of #6147.

Note: See TracTickets for help on using tickets.