Opened 7 years ago

Closed 7 years ago

#7613 closed defect (fixed)

Wired.com images broken

Reported by: pde Owned by: dtauerbach
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Reported in IRC:

<KBentley57> [20:40:00] Hey guys, I came here to report a bug I think I'm having with version 3.0.4.  When I try to visit wired.com, none of the images display on the homepage; they are also missing in the articles for the most part.  When I restart firefox in safe mode, it works, and when I disable https-everywhere, it starts to work again.
<KBentley57> [20:40:14] I'
<KBentley57> [20:40:56] I'm running Ubuntu 12.10 x64, Firefox 17, a few other add ins

Child Tickets

Change History (3)

comment:1 Changed 7 years ago by dtauerbach

Owner: changed from schoen to dtauerbach
Status: newassigned

comment:2 Changed 7 years ago by dtauerbach

Wired uses jquery-based lazy-loading of images (http://www.appelsiini.net/projects/lazyload), which appears to load a tiny 1x1 pixel first, later replacing it with the real image when the user scrolls by (e.g. <img src="/images/1x1.trans.gif" data-lazy-src="http://www.wired.com/images_blogs/gadgetlab/2012/12/maps_bg.jpg" alt="blunder down under" />). The issue is that the 1x1 pixel is being rewritten by the Conde Nast ruleset (in the above example: https://secure.wired.com/images/1x1.trans.gif). This seems to break lazy-loading. Since the images will load over HTTP anyway, I think disabling the part of the ruleset responsible for the image rewrites is an acceptable solution.

comment:3 Changed 7 years ago by dtauerbach

Resolution: fixed
Status: assignedclosed

Ended up disabling the rulesets in 2dd5ba7b2feb4eb5c140d33418539ca1ca588d8e

Note: See TracTickets for help on using tickets.