Opened 7 years ago

Closed 6 years ago

#7615 closed defect (fixed)

Ooyala (partial) rule causes Flash to throw error #2048 on byutv.org

Reported by: ParticleMan Owned by: jsha
Priority: High Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version: HTTPS-E 3.0.4
Severity: Keywords: httpse-ruleset-bug
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

With Ooyala (partial) enabled on byutv.org, videos are unplayable because Flash throw errors #2048.

HTTPS-E 3.0.4 Firefox (which is not in the version dropdown, which should be sorted) and HTTPS-E 2012.10.31 Chrome.

Child Tickets

Change History (8)

comment:1 Changed 7 years ago by pde

Version: HTTPS-E 3.0.2HTTPS-E 3.0.4

I can't get videos on byutv.org to play even in a browser without HTTPS Everywhere.

Speculating, it's possible that the Ooyala ruleset needs to have crossdomain.xml excluded like this:

<exclusion pattern="crossdomain\.xml$" />

or shouldn't contain a securecookie directive. If someone can reproduce cleanly, perhaps they could try those two changes to the Oooyala ruleset?

comment:2 Changed 7 years ago by mikeperry

Keywords: httpse-ruleset-bug added

comment:3 Changed 7 years ago by cypherpunks

If I recall correctly, I managed to reproduce this issue, and the crossdomain.xml exclusion is sufficient to resolve it (I did not have to remove the securecookie).

comment:4 Changed 7 years ago by pde

ICRC the fix should be in git now.

comment:5 Changed 7 years ago by schoen

Status: newneeds_information

The fix is definitely in git. We will have a release today which includes it (in case the last one didn't); can the original reporter then try that and see if the problem is fixed?

comment:6 Changed 7 years ago by ParticleMan

It's fixed at least in 4.0development.5 for Firefox.
It's not fixed in 2013.1.18 for Chrome.

comment:7 Changed 6 years ago by jsha

Owner: changed from pde to jsha
Status: needs_informationaccepted

comment:8 Changed 6 years ago by jsha

Resolution: fixed
Status: acceptedclosed
Note: See TracTickets for help on using tickets.