Opened 7 years ago

Closed 6 years ago

#7627 closed defect (fixed)

Comments on blogs.msdn.com don't show

Reported by: cypherpunks Owned by: zyan
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords: comments blogs.msdn.com
Cc: Actual Points:
Parent ID: #7851 Points:
Reviewer: Sponsor:

Description

Example of a link where this happens:
blogs.msdn.com/b/oldnewthing/archive/2012/12/03/10373882.aspx?Redirected=true#comments
When the Chrome extension HTTPS Everywhere is loaded, the comments don't show, instead it says Loading... forever.
Version (couldn't find it in the list): 2012-10-13

Child Tickets

Change History (3)

comment:1 Changed 7 years ago by cypherpunks

The site also doesn't display articles correctly over https (probably CSS etc being delivered using http). It should be removed from redirect attempts.

comment:2 Changed 6 years ago by zyan

Component: HTTPS Everywhere: ChromeEFF-HTTPS Everywhere
Owner: changed from pde to zyan
Parent ID: #7851
Status: newassigned

Commenter #1, the css issue has been reported and fixed (was due to mixed content loading).

The original bug is reproducible in FF23, even with mixed content blocking disabled. I suspect it is an instance of #7851 but need to do more digging.

comment:3 Changed 6 years ago by zyan

Resolution: fixed
Status: assignedclosed

Fixed for now by excluding the blogs subdomain.

Note: See TracTickets for help on using tickets.