Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7636 closed defect (duplicate)

setting socks port for TBB in OS X

Reported by: garrettr Owned by: chiiph
Priority: Low Milestone:
Component: Archived/Vidalia Version: Tor: 0.2.3.25
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I'm running the latest Tor Browser Bundle (2.3.25-1) on OS X 10.7. In previous TBB's it was possible to change the SocksPort on the bundle's version of Tor, which made it easier to configure other applications to use the TBB's instance of Tor as a proxy. There appears to be no working mechanism to do this in the current version.

Here are some of the failed ways I have tried to set the SOCKS port:

  1. edit the torrc via Vidalia's preferences: Vidalia > Settings > Advanced > Edit current torrc

This fails with the bug described in tickets #6147#7299.

  1. edit the torrc manually at its location in path/to/TorBrowser_en-US.app/Library/Vidalia/torrc

This has no effect on the running configuration. Revisiting the torrc via "Edit current torrc" in the Preferences shows the changes that have been made, but they do not affect the process. It still logs that it is opening the SOCKS port and control port on IP:0 (randomly chosen).

  1. edit the vidalia.conf manually (same dir as torrc). Set AutoControl=false (with the previous changes to the torrc), recommended as a workaround in #4379. Still no change.

It appears that one of the above tickets may be close to resolution; others suggest non-functional workarounds or are over a year old. If this ticket is unnecessary please feel free to delete or mark as a dupe - I just wanted to make sure people are aware of some highly unexpected behavior (especially the ignoring of the torrc, which I find to be quite disturbing).

Child Tickets

Change History (2)

comment:1 Changed 8 years ago by mo

Resolution: duplicate
Status: newclosed

Until #6147 is fixed, close Vidalia/Tor, make the torrc change, and start Vidalia again. To apply changes to the running Tor instance, remove all comments within the torrc editor in Vidalia.

Marking as dup of #6147 because you are reporting the same bug.

comment:2 Changed 8 years ago by arma

So long as you like having your socksport be 9050, you might be happier with https://www.torproject.org/docs/faq#TBBSocksPort as your solution.

Note: See TracTickets for help on using tickets.