Opened 8 years ago

Closed 7 years ago

#7647 closed defect (fixed)

TorBrowser update and no longer working

Reported by: rulemer Owned by: erinn
Priority: High Milestone: TorBrowserBundle 2.3.x-stable
Component: Applications/Tor bundles/installation Version:
Severity: Keywords: Another Tor process running Vidalia authenticate
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hi, there are a bunch of other tickets with this problem, but none that I can see with a solution for Mac OS X 10.6.8 (64 bit)

Tor Browser was running fine until I updated it today - I downloaded the new version and ran it, it came up with "Vidalia was unable to authenticate to the Tor software. (Control socket is not connected.) Please check your control port authentication settings."

I thought I better go back to the old version I was using of TorBrowser and just stay with that until things were working again, but for some reason that wasn't working either. So I tried a few different versions and none of them work now

When I check the message log I get "It looks like another tor process is running with the same data directory". So I tried deleting every version from my comp and then reinstalling one, still wasn't working. Any Ideas?

cheers for your time

Child Tickets

Change History (5)

comment:1 Changed 8 years ago by sysrqb

Component: TorTor bundles/installation
Owner: set to erinn

comment:2 Changed 8 years ago by erinn

Open /Applications/Utilities/Activity Monitor.app and look for a tor or vidalia process and if you see them, click the "Quit Process" button. Once that is done, can you try restarting the old one and tell me if it works? And if that doesn't work, make sure there are no lingering processes in the Activity Monitor and try running an older version and let me know if that works? I'm looking into this bug now.

comment:3 Changed 7 years ago by rulemer

Yeah I tried that, nothing showed up, so I deleted everything I had to do with Tor. Well, I tried to, trash wouldn't empty because two tor things were running so I did a secure empty trash to get rid of them. Still wouldn't start up though, even though there's seemingly no trace of tor left in my system

comment:4 Changed 7 years ago by arma

Status: newneeds_information

I assume you still have some Tor thing running on your computer.

I'm not sure how to guess what it is though without being you.

comment:5 Changed 7 years ago by rulemer

Resolution: fixed
Status: needs_informationclosed

Well I started using Orbot on my Android phone, that worked for a bit. Came back to my Mac one and it seemed to be working with seemingly no change but time. Weird... But I'm online now :)

Note: See TracTickets for help on using tickets.