Opened 8 years ago

Closed 6 years ago

#7649 closed defect (fixed)

Vidalia bridge/relay/exit bundles missing libssp-0.dll

Reported by: cypherpunks Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords: libssp-0.dll, needs-triage
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The copy of Tor found in the expert bundle for Windows version 0.2.3.25 fails to launch on Vista due to a missing libssp-0.dll.

I was able to find this file in one of the Vidalia bundles and moving it to Tor's install directory resolves the issue. However if Tor can no longer be run as a stand-alone executable any required .dlls should be included in the distribution packages.

Child Tickets

Change History (10)

comment:1 Changed 8 years ago by AdamColligan

I have experienced the same problem. Win7x64, new Vidalia Relay Bundle.

comment:2 Changed 8 years ago by erinn

Hi, I fixed this in the expert package. This definitely should not be happening in the vidalia bundles though, looking into that now...

comment:3 Changed 8 years ago by noino

Confirming, was having this problem in Win XP 32 - updated package working as designed

:=) Thanks, Erinn

comment:4 in reply to:  2 Changed 8 years ago by AdamColligan

Replying to erinn:

Hi, I fixed this in the expert package. This definitely should not be happening in the vidalia bundles though, looking into that now...

So what I have right now is a freshly-downloaded relay bundle with the default torrc accepted (just downloaded this hour). Events are:

  1. Vidalia GUI opens fine
  1. But when starting Tor, Vidalia throws error "Vidalia detected that the Tor software exited unexpectedly. Please check the message log for recent warning or error messages."
  1. Message log in Vidalia GUI is empty.
  1. In Vidalia message log GUI, added logging to file all the way to debug level. Vidalia will create the log file, but after Tor start error, nothing is actually logged.
  1. In torrc, added line "Log debug file c:\users\[me]\desktop\filename.txt" (also tried .log). After Vidalia's Tor start failure, no file is created; nothing written to that file if pre-existing.
  1. (Unrelated?). In Vidalia GUI, clicking "edit current torrc" launches the editor but shows only a blank file. Navigating to the file as displayed in the Vidalia GUI's "Tor Configuration File" path and opening it with WordPad shows that the torrc is in fact populated with both commented-out and active settings. Lines added through the GUI's torrc editor do not modify the file.
  1. Double-clicking the Tor application itself throws the libssp-0 error.

comment:5 Changed 8 years ago by cypherpunks

Thanks Erinn, the expert bundle version 0.2.3.25-win32-1 works as expected.

Also, replacing the tor.exe in the Vidalia bundles with the tor.exe from the expert bundle version 0.2.3.25-win32-1 appears to resolve the problem with Vidalia.

comment:6 Changed 8 years ago by cypherpunks

Resolution: fixed
Status: newclosed

comment:7 Changed 8 years ago by runa

Resolution: fixed
Status: closedreopened
Summary: The copy of Tor found in the expert bundle for Windows version 0.2.3.25 fails to launch due to a missing libssp-0.dll.Vidalia bridge/relay/exit bundles missing libssp-0.dll

A user reported that the Vidalia bridge/relay/exit bundles do not work. I tested the Vidalia Bridge Bundle on Windows 7; Vidalia starts, but is unable to start Tor. Starting Tor on its own results in the following message: The program can't start because libssp-0.dll is missing from your computer. Try reinstalling the program to fix this problem.

comment:8 Changed 8 years ago by Tasaar

Reinstalling doesn't do anything. The file is still missing...

comment:9 Changed 6 years ago by erinn

Keywords: needs-triage added

comment:10 Changed 6 years ago by cypherpunks

Resolution: fixed
Status: reopenedclosed

Vidalia is deprecated, no Vidalia bridge/relay/exit bundles anymore.

Note: See TracTickets for help on using tickets.