Opened 11 years ago

#769 closed defect (Works for me)

Firefox 3 slows

Reported by: bugmenot Owned by:
Priority: Low Milestone:
Component: Applications/Torbutton Version: 1.2.0rc5
Severity: Keywords:
Cc: bugmenot, arma Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

A page containing 50 iframes with no src attibute, is loaded by FF3 in one second.
If torbutton extension is active, even if tor is not active (tor disabled),
the same page takes about one minute to load, and during this period, the CPU is busy.

[Automatically added by flyspray2trac: Operating System: All]

Child Tickets

Change History (5)

comment:1 Changed 11 years ago by mikeperry

Can you attach an example html page, or a url that exhibits this behavior? Torbutton does attempt to
perform caching for these page elements, but perhaps something about this particular page is
preventing it.

comment:2 Changed 11 years ago by bugmenot

For example http://ig31.nisu.org/sample.html
I have other extensions on my FF3. I have concluded that is torbutton who produces the efect using try-and-error
Perhaps is the interaction with other extension ...
Thanks

comment:3 Changed 11 years ago by mikeperry

Adblock Plus will potentially also cause this problem. It seemed reasonable for me to load this page in a vanilla profile.
I checked and it looked like the caching mechanisms were working.. It may just be that this is the cost of doing business.. But I will leave this bug open, especially if you can update with info on Torbutton on a fresh FF3 profile on your system.

comment:4 Changed 11 years ago by mikeperry

Adblock Plus will potentially also cause and/or aggravate this problem. It seemed reasonable for me to load this page in a vanilla profile, though. I checked and it looked like the caching mechanisms were working.. It may just be that this is the cost of doing business.. But I will leave this bug open, especially if you can update with info on Torbutton on a fresh FF3 profile on your system.

comment:5 Changed 11 years ago by mikeperry

flyspray2trac: bug closed.
Just checked again, page took a second to load for me. Will save page as reference for future perf tests though.

Note: See TracTickets for help on using tickets.