Opened 6 years ago

Closed 6 years ago

#7725 closed enhancement (implemented)

Consensus-health checker should check authority versions

Reported by: karsten Owned by:
Priority: Medium Milestone:
Component: Metrics/Website Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

The consensus-health checker script should check whether authorities are running unrecommended Tor versions. It should exclude "too new" versions from those warnings, or it will be too noisy. Maybe it's sufficient to simply accept a "-dev" version if the string preceding "-dev" is a recommended version.

Child Tickets

Change History (4)

comment:1 Changed 6 years ago by karsten

Resolution: wontfix
Status: newclosed

I asked directory authority operators, and apparently there's no interest for this feature. Closing as wontfix.

comment:2 Changed 6 years ago by Sebastian

I thought the feature was already added. I only check warnings for gabelmoo, but I would certainly want the warning if it triggered.

comment:3 Changed 6 years ago by karsten

Resolution: wontfix
Status: closedreopened

comment:4 Changed 6 years ago by karsten

Resolution: implemented
Status: reopenedclosed
Note: See TracTickets for help on using tickets.