Opened 7 years ago

Closed 3 years ago

Last modified 3 years ago

#7734 closed defect (fixed)

Something tried to close an or_connection_t without going through channels at src/or/connection.c:3138

Reported by: cypherpunks Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version:
Severity: Normal Keywords: tor-client bufferevents
Cc: andrea Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

[notice] Tor 0.2.4.6-alpha-dev (git-c8056dcbbb9b468f)
...
[warn] Something tried to close an or_connection_t without going through channels at src/or/connection.c:3138

Child Tickets

Attachments (1)

FreeBSD_Tor_port_config.png (19.5 KB) - added by U+039b 3 years ago.
FreeBSD Tor port configuration

Download all attachments as: .zip

Change History (15)

comment:1 Changed 7 years ago by cypherpunks

The warning still occurs in the latest git snap

[notice] Tor 0.2.4.6-alpha-dev (git-b1ff8daeb521d164)
...
[warn] Something tried to close an or_connection_t without going through channels at src/or/connection.c:3138

comment:2 Changed 7 years ago by nickm

Cc: andrea added
Keywords: tor-client bufferevents added
Milestone: Tor: 0.2.4.x-final

Looks like this should only happen if you're running with bufferevents. Are you running with bufferevents? They're kind of buggy still. Nonetheless, we should fix this.

comment:3 Changed 7 years ago by fk

I'm not the OP, but I can confirm that compiling without bufferevents seems to workaround the problem.

comment:4 Changed 7 years ago by nickm

Milestone: Tor: 0.2.4.x-finalTor: 0.2.5.x-final

comment:5 Changed 6 years ago by nickm

Milestone: Tor: 0.2.5.x-finalTor: 0.2.???

comment:6 Changed 3 years ago by arma

Severity: Normal

A user on #tor reports a similar log line (connection.c:3722) in Tor 0.2.7.6.

He also apparently had bufferevents on. Apparently the FreeBSD ports option makes it easy to click "yes turn bufferevents on". :(

Changed 3 years ago by U+039b

Attachment: FreeBSD_Tor_port_config.png added

FreeBSD Tor port configuration

comment:7 Changed 3 years ago by U+039b

On FreeBSD,

cd /usr/ports/security/tor

make config

shows if bufferevents is enabled or not. See  FreeBSD_Tor_port_config.png

comment:8 Changed 3 years ago by U+039b

I filed a ticket on FreeBSD bugzilla: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=210389

comment:9 Changed 3 years ago by yurivict271

This bug needs to be clarified. Is there a bug in the FreeBSD port, or is bufferevents option generally broken?

Last edited 3 years ago by yurivict271 (previous) (diff)

comment:10 Changed 3 years ago by arma

The bufferevents option is broken and not to be used. Anything that enables it is definitely buggy, and anything that gives users the option to enable it should have that fixed too.

We've removed that option entirely from Tor 0.2.9.x.

I wonder if that means we should close this ticket and ones like it? Either with wont-fix, or with I-did-fix-and-the-fix-was-to-rip-it-out?

comment:11 Changed 3 years ago by yurivict271

Close it then.

comment:12 Changed 3 years ago by teor

Resolution: fixed
Status: newclosed

Fixed by removing the feature that had the bug.

comment:13 Changed 3 years ago by teor

Milestone: Tor: 0.2.???Tor: 0.3.???

Milestone renamed

comment:14 Changed 3 years ago by nickm

Milestone: Tor: 0.3.???

Milestone deleted

Note: See TracTickets for help on using tickets.