Opened 7 years ago

Closed 7 years ago

#7770 closed defect (not a bug)

Firefox Cannot Connect To Tor

Reported by: Jessica_XY Owned by:
Priority: Medium Milestone:
Component: Core Tor/Tor Version: Tor: 0.2.4.6-alpha
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I'm using Windows 7 64 bit on my laptop, with TOR and Vidalea installed. Everything works fine at home with Firefox (SOCKS 5, 127.0.0.1 and port 9050).

When I use TOR at school (for privacy, not to defeat site blockers) TOR connects perfectly, showing me the green onion. However, Firefox refuses to connect to TOR at the specified port and IP. I know TOR works since it works perfectly at home with the exact settings.

I've tried turning off my firewall... the school is not blocking TOR, but rather blocking me from connecting to 127.0.0.1. Is that even possible? The Chinese gov. can't block TOR, but my school can.

Also, I can add that the same problem happens on my Android phone with Orbot... it works perfectly at home but Orweb can't connect to the proxy even though Orbot says its connected.

I've tried polipo... no luck. If this is not a problem with TOR, let me know.

Child Tickets

Attachments (1)

9850f3d64abded6f269403db5c699f9a28605731.jpg (35.9 KB) - added by rransom 7 years ago.
bayimg.com/JahFbaAEj

Download all attachments as: .zip

Change History (8)

comment:1 Changed 7 years ago by cypherpunks

comment:2 Changed 7 years ago by Jessica_XY

Doesn't work. Same problem.

comment:3 Changed 7 years ago by cypherpunks

Are you using the same laptop at home and at school? What firewall used? Could you post logs from school's tor sessions? (Vidalia: "Message Log", "Advanced" tab, "Save All" button).

comment:4 Changed 7 years ago by Jessica_XY

Windows Firewall... with TOR clearly "ALLOWED". I've even turned it off to try... its not set to "Public Network" or anything like that.

Yes - same laptop. Below is the log (at school) on my XP laptop, also with TOR and Outpost Firewall (off). It's a regular TOR log, the same as the one at home. There's nothing wrong with TOR... I have used the same laptop and Orbot phone at hotels, restaurants, friends' houses, etc. without problem. Somehow, the school is blocking it when the Chinese government can't.

http://bayimg.com/JahFbaAEj

Changed 7 years ago by rransom

bayimg.com/JahFbaAEj

comment:5 in reply to:  4 Changed 7 years ago by rransom

Status: newneeds_information

Replying to Jessica_XY:

Windows Firewall... with TOR clearly "ALLOWED". I've even turned it off to try... its not set to "Public Network" or anything like that.

Yes - same laptop. Below is the log (at school) on my XP laptop, also with TOR and Outpost Firewall (off). It's a regular TOR log, the same as the one at home. There's nothing wrong with TOR... I have used the same laptop and Orbot phone at hotels, restaurants, friends' houses, etc. without problem. Somehow, the school is blocking it when the Chinese government can't.

The Chinese government does a fine job of blocking Tor clients from connecting to the Tor network.

Your problem is that Firefox cannot connect to the Tor client within your computer, and if you want someone to help diagnose what is going wrong, you need to post a Tor log from the computer which has the problem, showing Tor's output while it is having the problem.

comment:6 Changed 7 years ago by Jessica_XY

Ill post back when I go back to school after the holidays.

comment:7 Changed 7 years ago by Jessica_XY

Resolution: not a bug
Status: needs_informationclosed

Whatever... I dont really need TOR anyways. CLOSED.

Note: See TracTickets for help on using tickets.