Opened 11 years ago

#778 closed defect (Fixed)

Even if US Spoofing is desactivated navigator as an old User Agent

Reported by: amis Owned by:
Priority: High Milestone:
Component: Applications/Torbutton Version: 1.2.0rc5
Severity: Keywords:
Cc: amis Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Without Tor ( No Tor mode)
HTTP_USER_AGENT: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16
HTTP_ACCEPT_LANGUAGE: fr,fr-fr;q=0.8,en-us;q=0.5,en;q=0.3
Tor Mode without US Spoofing
HTTP_USER_AGENT: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
HTTP_ACCEPT_LANGUAGE: fr,fr-fr;q=0.8,en-us;q=0.5,en;q=0.3
Tor Mode with US Spoofing
HTTP_USER_AGENT: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
HTTP_ACCEPT_LANGUAGE: en-us,en;q=0.5

All without restart of Firefox. Could give help to the traffic partition analyser.

[Automatically added by flyspray2trac: Operating System: All]

Child Tickets

Attachments (1)

torbutton-1.2.0rc6-dev.xpi (192.3 KB) - added by mikeperry 11 years ago.
Snapshot that should fix the problem.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 11 years ago by mikeperry

Try the attached snapshot and let me know if it fixes it. Seems to be ok for me, but you've
had other random issues with locale as well.

Changed 11 years ago by mikeperry

Attachment: torbutton-1.2.0rc6-dev.xpi added

Snapshot that should fix the problem.

comment:2 Changed 11 years ago by mfr

Ok it's perfect you can close this one !

comment:3 Changed 11 years ago by mfr

Tor Mode + US Spoofing
HTTP_USER_AGENT: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16
HTTP_ACCEPT_LANGUAGE: en-us,en;q=0.5
Tor Mode without US Spoofing
HTTP_USER_AGENT: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16
HTTP_ACCEPT_LANGUAGE: fr,fr-fr;q=0.8,en-us;q=0.5,en;q=0.3
No Tor Mode
HTTP_USER_AGENT: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16
HTTP_ACCEPT_LANGUAGE: fr,fr-fr;q=0.8,en-us;q=0.5,en;q=0.3
All it's perfect.

comment:4 Changed 11 years ago by mikeperry

flyspray2trac: bug closed.
Fixed in 1.2.0

Note: See TracTickets for help on using tickets.