Opened 7 years ago

Closed 7 years ago

#7808 closed defect (fixed)

WashingtonPost.com busted - returning 504

Reported by: cypherpunks Owned by: pde
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version: HTTPS-E 4.0dev4
Severity: Keywords: httpse-ruleset-bug
Cc: MB Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Going to http://washingtonpost.com (and having it redirect to https) yeilds a 504 with the response:

---
An error occurred while processing your request.

Reference #97.7c0d0317.1356663462.746961a
---
Headers:
Connection keep-alive
Content-Length 175
Content-Type text/html
Date Fri, 28 Dec 2012 03:03:08 GMT
Expires Fri, 28 Dec 2012 03:03:08 GMT
MIME-Version 1.0
Server AkamaiGHost
Vary Accept-Encoding
---

To avoid the problem, I've added a boolean config property: extensions.https_everywhere.washingtonpost.com = false

I'm using FF 16.02 on OSX 10.5.8.

Child Tickets

Change History (3)

comment:1 Changed 7 years ago by pde

Cc: MB added
Version: HTTPS-E 3.1HTTPS-E 4.0dev4

Are you sure you're seeing this with HTTPS Everywhere 3.1? As far as I can tell, the ruleset in version 3.1 shouldn't affect a page load of the Washington Post homepage.

The story might be different for HTTPS Everywhere 4.0development.4, but that's working for me over HTTPS.

comment:2 Changed 7 years ago by mikeperry

Keywords: httpse-ruleset-bug added

comment:3 Changed 7 years ago by pde

Resolution: fixed
Status: newclosed

Hmmm, I have seen some problems with some articles in the development branch, so disabling that ruleset.

Note: See TracTickets for help on using tickets.