Opened 6 years ago

Closed 6 years ago

#7809 closed task (not a bug)

Can .manifest files be included in the binaries?

Reported by: bastik Owned by: aallai
Priority: Low Milestone:
Component: Archived/Flashproxy Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Unless there is a reason for the .manifest files being separate files, how about including them in the binary?

Currently the bundle contains "flashproxy-xyz.exe" without version information. Each file has its corresponding .manifest file.

On Windows you can right click on a file and select "properties". There's a tab called "details". I assume the manifest information would go there.

If there's the reason for the .manifest files this ticket is INVALID.

(This defaults to David, although he might not be responsible)

Child Tickets

Change History (4)

comment:1 Changed 6 years ago by dcf

Owner: changed from dcf to aallai
Status: newassigned

I'll assign to aallai as he may know more about this.

As far as I know, the .manifest files are made as a side effect of PyInstaller.

If this is wrong or doesn't make sense, feel free to close the ticket.

comment:2 Changed 6 years ago by aallai

It would make sense for them to be embedded, there is a ticket on the pyinstaller bug tracker about this: http://www.pyinstaller.org/ticket/639. I'll look into it.

comment:3 Changed 6 years ago by bastik

Priority: normalminor

Thank you for linking the ticket.

I changed the priority, because I don't expect people to care about them. I don't many expect them to look in the APP folder.

comment:4 Changed 6 years ago by dcf

Resolution: not a bug
Status: assignedclosed

I'm not worried about this. Apparently it's something that will change in a future release of PyInstaller per the bug linked above, so we'll pick it up when they make the change.

Note: See TracTickets for help on using tickets.