Opened 7 years ago

Closed 7 years ago

#7855 closed defect (fixed)

wouldMatch is not defined -> cookies set in JS not secured

Reported by: cypherpunks Owned by: pde
Priority: High Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version: HTTPS-E 3.1.2
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Using Firefox 19 and HTTPS-Everywhere 3.1, the following error appears in the error console about every three (!) seconds:

Error: wouldMatch is not defined
Source file: chrome://https-everywhere/content/code/HTTPSRules.js
Line: 659

Child Tickets

Attachments (1)

0001-Fixed-call-to-wouldMatch-in-wrong-scope.patch (802 bytes) - added by cypherpunks 7 years ago.
Patch v1

Download all attachments as: .zip

Change History (10)

comment:1 Changed 7 years ago by cypherpunks

Version: HTTPS-E 3.1HTTPS-E 3.1.2

Happens in 3.1.2, too.

comment:2 Changed 7 years ago by pde

Cc: mikeperry added
Priority: majorblocker
Summary: Firefox: Error: wouldMatch is not definedFirefox 19: Error: wouldMatch is not defined

It's possible that due to changes in http-on-modify-request, in Firefox 19, the apocalypse is coming.

comment:3 Changed 7 years ago by pde

This doesn't happen with all sites, but I can trigger it with HTTPS E 3.1.2, FF 19b2 and a visit to http://nytimes.com.

Changed 7 years ago by cypherpunks

Patch v1

comment:4 Changed 7 years ago by cypherpunks

Status: newneeds_review

comment:5 Changed 7 years ago by pde

Status: needs_reviewaccepted

I take it back. The apocalypse is not coming; this is a stupid bug I introduced by the fix for #7491. That patch won't do it, I think wouldMatch is actually the wrong thing to be calling.

comment:6 Changed 7 years ago by pde

Cc: mikeperry removed

comment:7 Changed 7 years ago by pde

Priority: blockermajor

https://gitweb.torproject.org/https-everywhere.git/commitdiff/7781a436230b9ee0a69c897c94a6a4252ad7e946

Gonna ship and test this in 4.0development.5. In the mean time, 3.1.x is suffering from a regression of #3766.

comment:8 Changed 7 years ago by pde

Summary: Firefox 19: Error: wouldMatch is not definedwouldMatch is not defined -> cookies set in JS not secured

comment:9 Changed 7 years ago by pde

Resolution: fixed
Status: acceptedclosed

This should be fixed in 4.0development.5.

Note: See TracTickets for help on using tickets.