Opened 7 years ago

Closed 6 years ago

#7867 closed defect (duplicate)

dir-spec doesn't specify ntor-onion-key

Reported by: sonu Owned by:
Priority: Medium Milestone: Tor: 0.2.4.x-final
Component: Core Tor/Tor Version:
Severity: Keywords: tor-relay tor-spec
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Section 2.1. of dir-spec does not specify descriptor 'ntor-onion-key' which is a part of /stem/test/data/cached-descriptors file which gives an "Unrecognized descriptor content" error message causing a failure in test_cached_descriptor

family $7E5F5B17CAA9BEF929F57D97EEFE305A2089E901
hidden-service-dir
contact +1 303-265-9283, rdump@OFTC
ntor-onion-key Od2Sj3UXFyDjwESLXk6fhatqW9z/oBL/vAKJ+tbDqUU=
reject 0.0.0.0/8:*
reject 169.254.0.0/16:*
reject 127.0.0.0/8:*

Child Tickets

Change History (5)

comment:1 Changed 7 years ago by nickm_mobile

Keywords: tor-relay spec added
Milestone: Tor: 0.2.4.x-final

comment:2 Changed 7 years ago by atagar

Hi Nick. What format do you think people utilizing this value will find the most convenient? Base64 encoded or something else? (context: I'm trying to figure out what stem's ServerDescriptor class should provide)

Thanks! -Damian

comment:3 Changed 7 years ago by nickm

I'm not really sure what a non-Tor user would use this for at all, other than checking its presence or absence. Base64 encoded would probably be fine.

comment:4 Changed 7 years ago by nickm

Keywords: tor-spec added; spec removed

Bulk-replacing "spec" and "torspec" keywords with "tor-spec".

comment:5 Changed 6 years ago by nickm

Resolution: duplicate
Status: newclosed

Calling this a duplicate of #8122 and broadening #8122

Note: See TracTickets for help on using tickets.