Opened 8 years ago

Closed 6 years ago

#7881 closed defect (fixed)

No update warning on check.torproject.org

Reported by: runa Owned by: erinn
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords: needs-triage
Cc: mikeperry Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

A few users have reported that they do not see an update warning on check.torproject.org when using the old TBB.

Child Tickets

Change History (9)

comment:1 Changed 8 years ago by erinn

Cc: mikeperry added

I don't get one either, even though I definitely updated the recommended-versions file... but I think the check has been behaving unpredictably for a while now. For the last version I was using (2.4.6-alpha-2) it would almost always say that TBB was out of date. Now with the same TBB it thinks I am up to date. I have no idea what's going on. Adding Mike to CC in case it is more of a Torbutton issue...

comment:2 Changed 8 years ago by arma

I wonder if it's related to the "do the check in parallel in the background, rather than up front before you can open any pages" design change.

comment:3 Changed 8 years ago by runa

Moving this from #7949, since that ticket was a duplicate of this one: I just started TBB 2.3.25-1 on OS X and expected to see the update message on check.tpo. This did not happen. For some reason, check.tpo does not warn TBB 2.3.25-1 users that their TBB is old.

For added fun, check.tpo tells me TBB 2.3.25-2 on Linux (x86_64) is old when the Tor Browser first launches. If I manually reload the page, check.tpo does not show the upgrade warning.

comment:4 Changed 8 years ago by erinn

Cc: phobos added

Adding phobos to CC. phobos, where is the check.torproject.org recommended-versions file stored? I want to see if it is out of date or not getting mirrored properly.

comment:6 Changed 8 years ago by erinn

Eh, yeah. Thanks. Removing phobos (sorry phobos!).

So, those are the right versions -- the ones that are available, the version file that's in git. I don't get an upgrade warning with an old bundle. I don't know how the version comparison happens or what might be going wrong in that process, I think we need Mike to weigh in.

comment:7 Changed 8 years ago by erinn

Cc: phobos removed

comment:8 Changed 6 years ago by erinn

Keywords: needs-triage added

comment:9 Changed 6 years ago by erinn

Resolution: fixed
Status: newclosed

Closing, since I don't think we've had issues with this in a while. Please reopen if it becomes a problem again.

Note: See TracTickets for help on using tickets.