Opened 7 years ago

Closed 2 years ago

#7884 closed defect (duplicate)

Have Tor publish one pluggable transport on multiple IPs?

Reported by: mo Owned by: asn
Priority: Low Milestone: Tor: unspecified
Component: Core Tor/Tor Version:
Severity: Normal Keywords: tor-bridge, pt
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

A user wants to set up Tor bridges and obfsproxies on multiple IPs. The easiest way to do so would be to have multiple ServerTransportPlugin lines using the same transport. Tor currently ignores such attempts.

From what I understand this is a "wontfix" because it would involve too many changes, but at least Tor should not silently ignore more than one STP line with the same transport listed.

Child Tickets

Change History (3)

comment:1 Changed 7 years ago by nickm

Milestone: Tor: unspecified

comment:2 Changed 4 years ago by isis

Possible duplicate: #11211

comment:3 Changed 2 years ago by nickm

Resolution: duplicate
Severity: Normal
Status: newclosed

Closing as duplicate of #11211 since there's more discussion there.

Note: See TracTickets for help on using tickets.