Opened 8 years ago

Closed 8 years ago

#7885 closed defect (fixed)

Atlas Fails on old Exit Node

Reported by: cypherpunks Owned by: hellais
Priority: Low Milestone:
Component: Metrics/Relay Search Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

I used to run an Exit Node @ https://atlas.torproject.org/#details/47DF93C269727DC04A54D84C016B62E54F8D1E27

Accessing this link now throws a javascript error:

Uncaught TypeError: Cannot read property 'advertised_bandwidth' of undefined relay.js:137
(anonymous function) relay.js:137
n jquery-min.js:2
o.fireWith jquery-min.js:2
w jquery-min.js:4
d

Child Tickets

Change History (2)

comment:1 Changed 8 years ago by karsten

Status: newneeds_review

This bug cannot be reproduced anymore, because there's an "advertised_bandwidth" value for that relay now. But Atlas should handle the case when there's no such value. That field is marked as optional in Onionoo's spec.

hellais, please review and merge my branch task-7885.

Thanks for reporting!

comment:2 Changed 8 years ago by karsten

Resolution: fixed
Status: needs_reviewclosed

Merged and deployed. Closing.

Note: See TracTickets for help on using tickets.