Opened 5 years ago

Closed 4 months ago

#7890 closed defect (fixed)

meaningless error message displayed by tor at start up

Reported by: mr-4 Owned by: nickm
Priority: Medium Milestone: Tor: 0.3.2.x-final
Component: Core Tor/Tor Version: Tor: 0.2.4.6-alpha
Severity: Normal Keywords: tor-client, usability, english, logging, easy, review-group-18
Cc: Actual Points: 0
Parent ID: Points: 0.1
Reviewer: Sponsor:

Description

During tor start up, I get the following gem: "No specified non-excluded exit routers seem to be running: can't choose an exit."

The first one who could decipher that for me will get a pat on the back.

I figured out the cause, eventually - I have restricted tor to use exit node (via ExitNodes), but that node was unavailable for some reason.

Child Tickets

Change History (9)

comment:1 Changed 5 years ago by nickm

Keywords: tor-client added
Milestone: Tor: unspecified

So, hm. What error message would have made more sense for that condition, where every exit router is either excluded via excludenodes, or not in exitnodes, or not running?

comment:2 Changed 5 years ago by mr-4

Using a double-negative never makes any sense, regardless of the context it is applied to. Perhaps something more down-to-earth, like what you just described above - in much simpler terms - ought to do the job?

comment:3 Changed 5 months ago by nickm

Keywords: usability english logging easy added
Points: 0.1
Severity: Normal

comment:4 Changed 5 months ago by nickm

Actual Points: 0
Milestone: Tor: unspecifiedTor: 0.3.2.x-final
Status: newneeds_review

Trivial fix in branch bug7890

comment:5 Changed 4 months ago by nickm

Keywords: review-group-18 added

comment:6 Changed 4 months ago by nickm

Owner: set to nickm
Status: needs_reviewassigned

setting owner

comment:7 Changed 4 months ago by nickm

Status: assignedneeds_review

comment:8 Changed 4 months ago by catalyst

Status: needs_reviewmerge_ready

The branch doesn't build for me currently, but it does build when cherry-picked onto master. (It looks like the branch was based on something that my compiler doesn't like.) Otherwise, it looks good to me.

comment:9 Changed 4 months ago by nickm

Resolution: fixed
Status: merge_readyclosed

thanks; merged!

Note: See TracTickets for help on using tickets.