Opened 6 years ago

Closed 6 years ago

#7911 closed defect (not a bug)

Tor making connections to local ISP DNS

Reported by: Nik Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version: Tor: 0.2.3.25
Severity: Keywords: tor-relay
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

My Tor process is making connections to all of the DNS servers configured on my machine. I have tried to see what's going on by checking out the message log, but to no avail.

I installed Tor according to official instruction. This should not be happening.

Child Tickets

Attachments (1)

Screenshot.png (509.5 KB) - added by Nik 6 years ago.

Download all attachments as: .zip

Change History (7)

Changed 6 years ago by Nik

Attachment: Screenshot.png added

comment:1 Changed 6 years ago by nickm

What's in your torrc?

comment:2 Changed 6 years ago by Nik

Please be more specific.

comment:3 Changed 6 years ago by nickm

Tor has configuration options. They are set in a file called "torrc". Do you have one? What is in it?

comment:4 Changed 6 years ago by Nik

I know what torrc is. Yes I have one. In it - comments and commented out options.

comment:5 Changed 6 years ago by nickm

Component: - Select a componentTor
Keywords: tor-relay added
Milestone: Tor: unspecified
Priority: blockernormal

I know this is going to sound like a stupid question, but are you 100% sure you're looking at the right torrc? Looking at your screenshot, I see that you have two external ports open listening for new connections -- *:9030 and *:9001. A Tor running in the default configuration doesn't listen on *any* external ports.

If one of those is an ORPort and one is a DirPort, then you're running as a public server. If that's the case, there's not a bug here -- it's normal for servers to use their DNS servers.

comment:6 Changed 6 years ago by Nik

Resolution: not a bug
Status: newclosed

I am running as a public service. I had a small suspicion this might have been causing these connections.

Thanks for the information.

Note: See TracTickets for help on using tickets.