Opened 7 years ago

Closed 7 years ago

#7913 closed defect (fixed)

Patch to get arm running on FreeBSD again

Reported by: fk Owned by: atagar
Priority: Medium Milestone:
Component: Core Tor/Nyx Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

8dbea0fa broke arm on FreeBSD for me.

$ ./arm
get_bsd_jail_id() takes exactly 1 argument (0 given)

The attached patch gets arm running again.

The jail detection appears to still be broken, but this seems to be an unrelated problem and I rediscovered some patches in a stem branch that look relevant.

I'll file a stem ticket about this once I have more information.

Child Tickets

Attachments (1)

arm-1.4.6_dev-0001-Get-arm-running-on-FreeBSD-again.patch (944 bytes) - added by fk 7 years ago.

Download all attachments as: .zip

Change History (3)

comment:1 in reply to:  description Changed 7 years ago by fk

Replying to fk:

The jail detection appears to still be broken, but this seems to be an unrelated problem and I rediscovered some patches in a stem branch that look relevant.

Never mind that.

The problems I'm seeing are unrelated to the jail code and I wasn't testing it correctly (expecting jls to be called when running arm inside a jail).

comment:2 Changed 7 years ago by atagar

Resolution: fixed
Status: newclosed

Thanks Fabian! Patch pushed.

I'm moving most of the utilities (next up being the connection resolvers) to stem. An advantage of this will be tests using sample data from FreeBSD. Hopefully this'll lead to fewer regressions on that platform.

Cheers! -Damian

PS. You might also be interested in #7930. I'm holding off an initial release and packaging until March to give the library more time to mature, but after that Carlo has offered to package for FreeBSD.

Note: See TracTickets for help on using tickets.