Opened 6 years ago

Closed 6 years ago

#7943 closed defect (worksforme)

Torbeowser logging history

Reported by: Mikeplaysfootball Owned by: mikeperry
Priority: Very High Milestone: TorBrowserBundle 2.3.x-stable
Component: TorBrowserButton Version:
Severity: Keywords: tbb-disk-leak
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Hello, i have noticed that my last browsing session was saved. I checked the preferences in the tor browser (most recent tor browser bundle) and they were set to use custom privacy settings with everything enabled, also saving passwords.

I have removed and reinstalled my normal firefox lately but that should have not made changes to the torbrowser?

Child Tickets

Change History (7)

comment:1 Changed 6 years ago by cwt96

Component: - Select a componentTorBrowserButton
Owner: set to mikeperry

comment:2 Changed 6 years ago by cwt96

Milestone: TorBrowserBundle 2.3.x-stable

comment:3 Changed 6 years ago by mikeperry

Keywords: tbb-disk-leak added

Do you mean saved as in a session restore after a crash? Or your history was recorded?

Right now, we use fine-grained individual preferences for the disk blocking, and a special filter for the session restore.

comment:4 Changed 6 years ago by Mikeplaysfootball

My browsing history was fully recorded with every website visited. Typing a letter into the url-bar it suggested previously visited websites to me. I checked and the prefs were set to save passwords and download history as well. I was using the most recent tor browser bundle downloaded from the official tor website. It was the second time I ran the bundle when I noticed the messed up privacy settings.

I can assure 100% that I have not manually changed the settings. As of now I assume that it was an installation problem or an attack on the browser, possibly caused by malicious javascript code.

comment:5 Changed 6 years ago by mikeperry

Do you still have the actual TBB bundle file that you downloaded? Can you give us the exact file name?

Also, if you know how, can you give us the sha1sum (or md5sum if sha1 is unavailable to you) of that file?

comment:6 Changed 6 years ago by Mikeplaysfootball

Unfortunately I panicked and removed the file without further inspection other than noticing the messed up privacy prefs, which -by the way- were identical to the default prefs in a normal firefox installation. I could not recreate the problem. I have reinstalled from the same installation-file and the settings were just as they were supposed to be.

That's why I assume that it either was an error on installation (which I find more unlikely and couldnt recreate that) or that the settings got messed with while browsing. The computer's OS was a fresh install and was free of rats and various anti-spyware tools and rootkit-scanners could not detect anything.

I think this will remain a mystery but I wanted to state it here just for references if some other people also notice weird changes in their preferences, especially the privacy ones.

comment:7 Changed 6 years ago by mikeperry

Resolution: worksforme
Status: newclosed

I am going to close this. If it happens again and/or we can figure out a way to reproduce, please reopen (or file a new issue if something actually causes the pref reset).

Note: See TracTickets for help on using tickets.