Opened 8 years ago

Closed 8 years ago

#7951 closed defect (not a bug)

[Ubuntu 12.04] Before Tor can create a control socket in "/var/run/tor/control", the directory "/var/run/tor" needs to exist, and to be accessible only by the user account that is running Tor.

Reported by: RedheadedCupcake Owned by: weasel
Priority: Medium Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

This is what the log says...I have no idea what I am doing

Jan 13 22:10:34.001 [Notice] Tor v0.2.2.35 (git-73ff13ab3cc9570d). This is experimental software. Do not rely on it for strong anonymity. (Running on Linux i686)
Jan 13 22:10:34.002 [Notice] Initialized libevent version 2.0.16-stable using method epoll. Good.
Jan 13 22:10:34.002 [Notice] Opening Socks listener on 127.0.0.1:9050
Jan 13 22:10:34.002 [Warning] Could not bind to 127.0.0.1:9050: Address already in use. Is Tor already running?
Jan 13 22:10:34.002 [Warning] /var/run/tor is not owned by this user (kat, 1000) but by debian-tor (121). Perhaps you are running Tor as the wrong user?
Jan 13 22:10:34.002 [Warning] Before Tor can create a control socket in "/var/run/tor/control", the directory "/var/run/tor" needs to exist, and to be accessible only by the user account that is running Tor. (On some Unix systems, anybody who can list a socket can conect to it, so Tor is being careful.)
Jan 13 22:10:34.002 [Warning] Failed to parse/validate config: Failed to bind one of the listener ports.
Jan 13 22:10:34.002 [Error] Reading config failed--see warnings above.

Child Tickets

Change History (2)

comment:1 Changed 8 years ago by erinn

Owner: changed from erinn to weasel
Status: newassigned

comment:2 Changed 8 years ago by arma

Resolution: not a bug
Status: assignedclosed

Replying to RedheadedCupcake:

I have no idea what I am doing

Sounds like you should avoid trying to start the tor process as your own user. You need to start it with 'sudo service tor start' or similar.

That said, assuming you're trying to use Tor as a client, you should be using the Tor Browser Bundle instead of the tor deb.

If you have further user questions, help@… is the right place.

Note: See TracTickets for help on using tickets.