Opened 7 years ago

Closed 7 years ago

#7957 closed defect (fixed)

Pinterest "pin fetching" broken by Pinterest ruleset.

Reported by: runa Owned by: pde
Priority: Medium Milestone:
Component: HTTPS Everywhere/EFF-HTTPS Everywhere Version:
Severity: Keywords: httpse-ruleset-bug
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Pinterest does not work in TBB 2.3.25-2 (I assume it doesn't work in any of the previous versions either). To reproduce:

The site is supposed to allow you to click on the image to be redirected to whatever site is hosting the article/recipe/post/etc that it links to.

Child Tickets

Change History (3)

comment:1 Changed 7 years ago by mikeperry

Component: TorBrowserButtonEFF-HTTPS Everywhere
Owner: changed from mikeperry to pde
Summary: Pinterest broken in TBB 2.3.25-2Pinterest "pin fetching" broken by Pinterest ruleset.

Bleh. Another ruleset bug. This speicific issue seems due to the ruleset for Pinterest itself. Disabling "Pinterest (partial)" in HTTPS-Everywhere allows it to fetch pins again (whatever that means).

comment:2 Changed 7 years ago by mikeperry

Keywords: httpse-ruleset-bug added

comment:3 Changed 7 years ago by pde

Resolution: fixed
Status: newclosed

Fixed in git, and forthcoming 3.1.3.

Note: See TracTickets for help on using tickets.