Opened 7 years ago

Closed 5 years ago

#7970 closed defect (duplicate)

Remove attic'ed bridges-spec.txt from NSIS installer

Reported by: cypherpunks Owned by: erinn
Priority: Low Milestone:
Component: Applications/Tor bundles/installation Version:
Severity: Keywords: package_nsis-mingw.sh, tor-mingw.nsi.in, Windows, installer, NSIS, bridges-spec.txt, attic, needs-triage
Cc: mo Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

NSIS Windows installer installs 'attic'ed specs as zero-byte files

The expert bundle installs a bridges-spec.txt, which is zero bytes. This spec is now in the 'attic', and probably should not be installed.

(There are also some other newer specs that aren't installed, that maybe should be.)

I am looking at the Windows expert bundle, v0.2.4.7-alpha and git.2013-01-03.51c2dd8.

These two files need updating: contrib/package_nsis-mingw.sh and contrib/tor-mingw.nsi.in.


File: contrib/package_nsis-mingw.sh

1) Remove references to bridges-specs.txt

You don't install any of the other specs in the attic, just bridges-spec.


for fn in address-spec.txt bridges-spec.txt control-spec.txt \

dir-spec.txt path-spec.txt rend-spec.txt socks-extensions.txt \
tor-spec.txt version-spec.txt; do
clean_newlines doc/spec/$fn win_tmp/doc/spec/$fn

done


2) consider adding new specs to NSIS scripts

These specs are not installed, maybe they should be?

gettor-spec.txt
glossary.txt
pt-spec.txt
tor-fw-helper-spec.txt

3) consider adding other new docs to NSIS scripts:

Specs aside, the NSIS script also installs these docs:

tor.html
torify.html
tor-gencert.html
tor-resolve.html
HACKING
README
ChangeLog
LICENSE

Are there any other newer docs you should be including?

Perhaps renaming the extensionless ASCII text files (HACKING, README, ChangeLog, LICENSE) to .txt would be more usable for Windows users?

I think you should install the FAQ, since the torrc comments tell the user to see the FAQ for info on how to use tor.exe as a service.

Perhaps the core proposals?

proposals/000-index.txt
proposals/001-process.txt
proposals/098-todo.txt
proposals/099-misc.txt

What about the design-paper/tor-design.pdf, and the later revised pdf? The earlier installers (eg, contrib/package_nsis.sh, used to install that).


File: contrib/tor-mingw.nsi.in

1) Remove references to bridges-specs.txt

In the NSIS function ExtractSpecs(), remove this line:

File "..\doc\spec\bridges-spec.txt"

Later on, in the function CreateDocLinks(), remove this line:

CreateShortCut "$SMPROGRAMS\Tor\Documents\Tor Bridges \
Specification.lnk" "$INSTDIR\Documents\bridges-spec.txt"

2) Consider adding a few more shortcuts to Start menu.

Right now you add an URL "Tor Website.url" to the main Tor web site. Perhaps it'd be useful to have a few others, for core Tor web sites, Compass, etc?

3) Consider adding manpage and spec subdirs to the Documents dir

You create a Documents directory to install the docs to. Right now, it's a bit crowded. It might be nice to create a manpages and specs subdirs under Documents.

4) Your lawyers will want you to update the copyright notices in the NSIS installer scripts, to something beyond 2009.


Thanks,
Lee

Child Tickets

Change History (7)

comment:1 Changed 7 years ago by rransom

Component: - Select a componentTor bundles/installation
Owner: set to erinn

comment:2 Changed 7 years ago by nickm

(Are we still building and supporting the expert bundles? If so, the right solution here is IMO to drop the *spec.txt files entirely.)

comment:3 in reply to:  2 Changed 7 years ago by rransom

Replying to nickm:

(Are we still building and supporting the expert bundles? If so, the right solution here is IMO to drop the *spec.txt files entirely.)

That was #3758.

comment:4 Changed 7 years ago by mo

Cc: mo added

comment:5 Changed 5 years ago by erinn

Keywords: needs-triage added

comment:6 Changed 5 years ago by arma

I suggest closing this one as a duplicate of #3758, and then doing #3758.

comment:7 Changed 5 years ago by nickm

Resolution: duplicate
Status: newclosed

Fine by me.

Note: See TracTickets for help on using tickets.