Opened 7 years ago

Closed 7 years ago

#7994 closed defect (fixed)

ooni instructions don't say required libdnet and pypcap versions

Reported by: arma Owned by: hellais
Priority: Medium Milestone:
Component: Archived/Ooni Version:
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

On https://github.com/hellais/ooni-probe#getting-started
it says "It's ideal to install these manually since the ones in debian or ubuntu are not up to date"

One day that statement will become false. Only you will know when that's the case. What is the version that you get from source right now? Is anything earlier than that acceptable?

Child Tickets

Change History (1)

comment:1 Changed 7 years ago by hellais

Resolution: fixed
Status: newclosed

Currently libdnet and pypcap are unmaintained for 3 and 6 years respectively. I added a note to the README stating which versions ooniprobe is tested with. Any other version should be considered not tested.

This was added to the README here:
https://github.com/TheTorProject/ooni-probe/commit/f734d026ef5e5010ea2064434d3b31760798139c

Note: See TracTickets for help on using tickets.