Opened 7 years ago

Closed 3 years ago

#8000 closed enhancement (duplicate)

TBB needs UI to access authenticated hidden services

Reported by: lunar Owned by: tbb-team
Priority: Low Milestone:
Component: Applications/Tor Browser Version:
Severity: Normal Keywords: tbb-usability, tbb-torbutton
Cc: lunar, arthuredelstein, patrick@… Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Tor support authenticated hidden services. Unfortunately, the easiest way to currently reach them is by modifying torrc.

It would be great if the TorBrowser would offer an easier interface to reach HTTP(S) authenticated hidden services.

A quick brainstorm lead to think that their could be two sides of this interface:

  • an option in the onion menu,
  • custom "Unable to connect" page for .onion that would say "maybe this hidden service requires an auth cookie" and a field to enter one.

Child Tickets

Change History (7)

comment:1 Changed 7 years ago by mikeperry

Keywords: tbb-usability added
Priority: normalminor
Summary: Add interface to access HTTP(S) authenticated hidden servicesTBB needs UI to access authenticated hidden services

This almost seems like a Tor Launcher bug.. I'll accept patches, but realistically not much is going to happen otherwise?

comment:2 Changed 6 years ago by arma

comment:3 Changed 5 years ago by erinn

Component: TorBrowserButtonTor Browser
Keywords: tbb-torbutton added
Owner: changed from mikeperry to tbb-team

comment:4 Changed 5 years ago by saint

I second this. It's currently very difficult to use an authenticated hidden service as a client.

comment:5 Changed 5 years ago by arthuredelstein

Cc: arthuredelstein added

comment:6 Changed 3 years ago by PZajda

Cc: patrick@… added
Severity: Blocker

comment:7 Changed 3 years ago by gk

Resolution: duplicate
Severity: BlockerNormal
Status: newclosed

The discussion happens/happened in #14389. Thus, marking this as a duplicate of it.

Note: See TracTickets for help on using tickets.