Opened 6 years ago

Closed 6 years ago

#8024 closed defect (fixed)

Tor Client : "circuit_package_relay_cell(): Bug: outgoing relay cell has n_chan==NULL. Dropping"

Reported by: cypherpunks Owned by: mikeperry
Priority: Medium Milestone: Tor: 0.2.4.x-final
Component: Core Tor/Tor Version: Tor: 0.2.4.9-alpha
Severity: Keywords: tor-client, MikePerry201301
Cc: andrea Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

[notice] Tor 0.2.4.9-alpha-dev (git-ee421e68d5231e39) opening new log file.
...
[warn] circuit_package_relay_cell(): Bug: outgoing relay cell has n_chan==NULL. Dropping.

Child Tickets

Change History (13)

comment:1 Changed 6 years ago by nickm

Component: - Select a componentTor
Keywords: tor-relay added
Milestone: Tor: 0.2.4.x-final

Is this a relay, or a client? (Tentatively classifying as tor-relay.)

comment:2 Changed 6 years ago by nickm

Version: Tor: 0.2.4.9-alpha

comment:3 in reply to:  1 Changed 6 years ago by cypherpunks

Replying to nickm:

Is this a relay, or a client? (Tentatively classifying as tor-relay.)

It's a client ... I've explicitely set ClientOnly 1 in the torrc and tor is listening only to local standard ports ( sock port 9050, control port 9051 , transparent proxy port 9040 , dns port 5353 )

comment:4 Changed 6 years ago by nickm

Keywords: tor-client added; tor-relay removed

comment:5 Changed 6 years ago by mikeperry

Keywords: MikePerry201301 added
Owner: set to mikeperry
Status: newassigned
I found an instance of this while testing #7802. It was caused by a path bias probe. I can add a check for circ->n_chan != NULL && (circ->n_chan->state == CHANNEL_STATE_OPEN
circ->n_chan->state == CHANNEL_STATE_MAINT) in pathbias_send_usable_probe(), unless there is a better fix.

comment:6 Changed 6 years ago by mikeperry

I pushed this fix (modulo DeMorgan) to mikeperry/bug7802 and restarted my testing. The check has been exercised successfully a few times already. It might take me a while to trigger the null condition though. I guess maybe my Internet connection must have dropped?

comment:7 Changed 6 years ago by mikeperry

Status: assignedneeds_review

comment:8 Changed 6 years ago by nickm

Cc: andrea added

That's not the format for a changes file. Otherwise, looks plausible, but I'd ask andrea to have a look to make sure it looks okay to her.

comment:9 Changed 6 years ago by nickm

(Assuming that a78542f0c30a6d8a25b3a8 is the commit in question)

comment:10 Changed 6 years ago by andrea

This looks fine to me; merging.

comment:11 Changed 6 years ago by andrea

Resolution: fixed
Status: needs_reviewclosed

Merged.

comment:12 Changed 6 years ago by andrea

Resolution: fixed
Status: closedreopened

Gah, I fail merging forever. That picked up mikeperry's 7802 branch too.

*off to do a quick review on that*

comment:13 Changed 6 years ago by nickm

Resolution: fixed
Status: reopenedclosed

We just did a little emergency post-merge review, and stuff looks basically okay. Closing this and #7802; Andrea is opening a new ticket with the issues we found during review.

Note: See TracTickets for help on using tickets.