Opened 8 years ago

Closed 8 years ago

#8083 closed enhancement (duplicate)

add "{??}" (or other suitable alternative) for specifying nodes

Reported by: mr-4 Owned by:
Priority: Medium Milestone: Tor: unspecified
Component: Core Tor/Tor Version: Tor: 0.2.4.9-alpha
Severity: Keywords: tor-client
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

Currently, if the origin of the IP address of a particular node is unknown, either due to messed-up GeoIP database, or due to tor having to rely on an outdated copy, there is no way to specify these nodes and include them in various *Nodes torrc options.

By adding something like the above option (or other similar syntax) this can be achieved.

Child Tickets

Change History (3)

comment:1 Changed 8 years ago by nickm

Keywords: tor-client added
Milestone: Tor: unspecified

Are you sure that {??} doesn't work? It's supposed to work.

See also #7706

comment:2 Changed 8 years ago by mr-4

Oh, that is exactly what I wanted! Is this documented anywhere?

If not, *please* document this very important feature (I was aware of the A? country issue simply because it appeared in one of the changelogs and was discussed on the tor mailing list as well), otherwise I am sure there would be many other stragglers, like myself, asking for this.

Thanks Nick, I added this in my ExcludeNodes list and hopefully it will do the job.

comment:3 Changed 8 years ago by nickm

Resolution: duplicate
Status: newclosed

I've added a note to the manpage on the feature7706 branch. I'm going to call this a duplicate of #7706 now.

Note: See TracTickets for help on using tickets.