Opened 15 months ago

Closed 15 months ago

Last modified 15 months ago

#8135 closed defect (not a bug)

Programs stopped working with Tor

Reported by: hifferymchumphrey Owned by:
Priority: normal Milestone:
Component: Tor Version: Tor: 0.2.3.25
Keywords: Cc:
Actual Points: Parent ID:
Points:

Description

Recently I've noticed that seamonkey -mail, Pidgin and tor-resolve have stopped working with Tor.
Im confused as to why 'seamonkey -browser' does work with foxyproxy but 'seamonkey -mail' does not. Perhaps it has something to do with tor accepting http/https protocols but not smtp/imap protocols?

foxyproxy gives ERROR MESSAGE: "exception while determining which host to use for proxying"
tor-resolve gives ERROR MESSAGE: "Error while connecting to SOCKS host: Connection refused"

An extract of the Pidgin Debug Window:

(18:42:45) account: Connecting to account y2012@…/Home.
(18:42:45) connection: Connecting. gc = 0x22090cd0
(18:42:45) dnssrv: querying SRV record for jabber.org: _xmpp-client._tcp.jabber.org
(18:42:45) dnssrv: found 2 SRV entries
(18:42:45) dnsquery: Performing DNS lookup for 127.0.0.1
(18:42:45) dnsquery: IP resolved for 127.0.0.1
(18:42:45) proxy: Attempting connection to 127.0.0.1
(18:42:45) proxy: Connecting to hermes.jabber.org:5222 via 127.0.0.1:9050 using SOCKS4
(18:42:45) proxy: Connection in progress.
(18:42:45) socks4 proxy: Connected.
(18:42:45) proxy: Connection attempt failed: Connection refused
(18:42:45) jabber: Unable to connect to server: Connection refused. Trying next SRV record or connecting directly.
(18:42:45) dnsquery: Performing DNS lookup for 127.0.0.1
(18:42:45) dnsquery: IP resolved for 127.0.0.1
(18:42:45) proxy: Attempting connection to 127.0.0.1
(18:42:45) proxy: Connecting to hermes6.jabber.org:5222 via 127.0.0.1:9050 using SOCKS4
(18:42:45) proxy: Connection in progress.
(18:42:45) socks4 proxy: Connected.
(18:42:45) proxy: Connection attempt failed: Connection refused
(18:42:45) jabber: Unable to connect to server: Connection refused. Trying next SRV record or connecting directly.
(18:42:45) dnsquery: Performing DNS lookup for 127.0.0.1
(18:42:45) dnsquery: IP resolved for 127.0.0.1
(18:42:45) proxy: Attempting connection to 127.0.0.1
(18:42:45) proxy: Connecting to jabber.org:5222 via 127.0.0.1:9050 using SOCKS4
(18:42:45) proxy: Connection in progress.
(18:42:45) socks4 proxy: Connected.
(18:42:45) proxy: Connection attempt failed: Connection refused
(18:42:45) jabber: Couldn't connect directly to jabber.org. Trying to find alternative connection methods, like BOSH.
(18:42:45) dnssrv: querying TXT record for jabber.org: _xmppconnect.jabber.org
(18:42:45) dnssrv: res_query returned an error
(18:42:45) jabber: Unable to find alternative XMPP connection methods after failing to connect directly.
(18:42:45) connection: Connection error on 0x22090cd0 (reason: 0 description: Unable to connect)
(18:42:45) account: Disconnecting account y2012@…/Home (0x21d112b8)
(18:42:45) connection: Disconnecting connection 0x22090cd0
(18:42:45) connection: Destroying connection 0x22090cd0

Child Tickets

Change History (3)

comment:1 Changed 15 months ago by cwt96

  • Component changed from - Select a component to Tor
  • Keywords Tor_crash added

comment:2 Changed 15 months ago by arma

  • Resolution set to not a bug
  • Status changed from new to closed

Sounds like you want https://www.torproject.org/docs/faq#TBBSocksPort ?

Please direct further support queries to the help@rt list: https://www.torproject.org/about/contact

comment:3 Changed 15 months ago by arma

  • Keywords Tor_crash removed
  • Milestone TorBrowserBundle 2.3.x-stable deleted
Note: See TracTickets for help on using tickets.