Opened 7 years ago

Closed 6 years ago

#8136 closed defect (fixed)

(CRASH) "Bug: outgoing relay cell has n_chan==NULL"

Reported by: cypherpunks Owned by:
Priority: High Milestone: Tor: 0.2.4.x-final
Component: Core Tor/Tor Version: Tor: 0.2.4.9-alpha
Severity: Keywords:
Cc: Actual Points:
Parent ID: Points:
Reviewer: Sponsor:

Description

17:37:33 [ARM_NOTICE] Tor control port closed
17:37:33 [ERR] connection_ap_expire_beginning(): Bug: src/or/connection_edge.c:649: connection_ap_expire_beginning: Assertion circ->purpose == CIRCUIT_PURPOSE_C_GENERAL failed; aborting.
17:37:26 [WARN] circuit_package_relay_cell(): Bug: outgoing relay cell has n_chan==NULL. Dropping.

Child Tickets

Change History (6)

comment:1 Changed 7 years ago by rransom

Resolution: duplicate
Status: newclosed

Probably a duplicate of #8065. Thanks for the report!

comment:2 Changed 6 years ago by cypherpunks

Feb 22 18:14:50.000 [notice] Rend stream is 120 seconds late. Giving up on address '[scrubbed].onion'.
Feb 22 18:16:50.000 [notice] Rend stream is 120 seconds late. Giving up on address '[scrubbed].onion'.
Feb 22 18:18:50.000 [notice] Rend stream is 120 seconds late. Giving up on address '[scrubbed].onion'.
Feb 22 18:20:50.000 [notice] Rend stream is 120 seconds late. Giving up on address '[scrubbed].onion'.
Feb 22 18:22:35.000 [err] connection_ap_expire_beginning(): Bug: src/or/connection_edge.c:654: connection_ap_expire_beginning: Assertion circ->purpose == CIRCUIT_PURPOSE_C_GENERAL failed; aborting.

comment:3 Changed 6 years ago by cypherpunks

Resolution: duplicate
Status: closedreopened

comment:4 Changed 6 years ago by cypherpunks

$ tor --version
Tor version 0.2.4.10-alpha (git-36abdfe7dcff3c65).

(Same guy who reopened ticket + pasted abort + created original ticket).

comment:5 Changed 6 years ago by nickm

Milestone: Tor: 0.2.4.x-final

comment:6 Changed 6 years ago by nickm

Resolution: fixed
Status: reopenedclosed

But .. that's a different warning than the original one.

In any case, as of 0.2.4.11-alpha, that's a warning message rather than an assertion (see bug #8065). So I think we can close this.

Note: See TracTickets for help on using tickets.