Opened 5 years ago

Closed 5 years ago

#8184 closed task (fixed)

Verify path bias code plays well with optimistic data

Reported by: mikeperry Owned by: mikeperry
Priority: Medium Milestone: Tor: 0.2.5.x-final
Component: Core Tor/Tor Version:
Severity: Keywords: tor-client 024-backport MikePerry201308
Cc: iang Actual Points:
Parent ID: #3890 Points: 2
Reviewer: Sponsor:

Description

In connection_ap_handshake_socks_reply() and some other places, we mark circuits as having successfully carried streams if we get certain end reason codes back. With optimistic data enabled, we may actually get these same end reason codes back even if the circuit/stream was damaged due to tagging after accepting an optimistic data stream attempt.

I probably need to instrument a tor client running with optimistic data to verify these codepaths can't happen.

Child Tickets

Attachments (1)

webfetch-4b-timing.diff (15.9 KB) - added by iang 5 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 5 years ago by nickm

Milestone: Tor: 0.2.4.x-final

comment:2 Changed 5 years ago by nickm

Status: newassigned

comment:3 Changed 5 years ago by mikeperry

Keywords: 024-deferrable added

Until some apps actually support optimistic data (see sibling tickets), there is no way for me to test this. Yes, I realize that I am the maintainer one of the apps that are guilty of lack of support, but that still doesn't mean that support has to be implemented by the 0.2.4.x-stable deadline.

comment:4 Changed 5 years ago by nickm

Drop iang a line? I know he's got at least some testing app that he & his students used when they implemented optimistic data..

(This should probably get done in 0.2.4, since optimistic data support went into 0.2.3, and breaking it in 0.2.4 would count as a regression.)

Changed 5 years ago by iang

Attachment: webfetch-4b-timing.diff added

comment:5 Changed 5 years ago by iang

Cc: iang added

The simplest test program I have is webfetch 5.4.3 (http://tony.aiu.to/sa/webfetch/) with the attached patch to enable reporting of timing and "SOCKS 4b" (like SOCKS 4a, but allow the client to send data before hearing the response to the connection attempt).

comment:6 Changed 5 years ago by mikeperry

Keywords: MikePerry201304 added

Thanks Ian.

comment:7 Changed 5 years ago by mikeperry

Keywords: MikePerry201305 added; MikePerry201304 removed

comment:8 Changed 5 years ago by nickm

Keywords: 024-backport added; 024-deferrable MikePerry201305 removed
Milestone: Tor: 0.2.4.x-finalTor: 0.2.5.x-final

Can't block 0.2.4 on this any longer. If we find any bugs, we can backport the fixes, if the fixes are easy.

comment:9 Changed 5 years ago by nickm

Keywords: MikePerry201305 added

whoops; removed Mike's magic tag.

comment:10 Changed 5 years ago by mikeperry

Keywords: MikePerry201307 added; MikePerry201305 removed

comment:11 Changed 5 years ago by mikeperry

Keywords: MikePerry201309 added; MikePerry201307 removed

It probably works? Seems to be fine so far. I think I might just let inertia take care of this one. Pushing this out to September.

comment:12 Changed 5 years ago by mikeperry

Keywords: MikePerry201308 added; MikePerry201309 removed
Points: 2
Resolution: fixed
Status: assignedclosed

I've gotten notices about low stream success counts while using optimistic data on bad connections. Calling this one closed.

Note: See TracTickets for help on using tickets.